Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

SharePoint 2003 Web capture and Office 2007/Vista

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 1 posts
I started using Vista with office 2003 and had no issues with our SharePoint site. I have some shared files on the site which opened fine and had no problem with credentials.

I upgraded to Office 2007 and since I've had to submit my credentials every time I open one of the files on "My Site." Which also does not connect as my home site like it did in office 2003. I've been looking for a fix for this for some time but I realize that Microsoft is no longer continuing their Microsoft Office Web Components line which is the most likely cause of the issue. If anyone knows how to keep from getting prompted for credentials every time I try to open a document saved on our SharePoint 2003 server it would be greatly appreciated but it is not my primary concern.

My major problem is I've recently been given the task of creating an IT site on our SharePoint Server. We run both SharePoint Server 2003 and Services. I have not done any of this before I upgraded to Office 2007 and do not have a computer with Vista Business and Office 2003 to test this on. I can add a Web Capture Web Part to the area but when I try to select a site for it to pull in I get an error:

"Cannot create or modify Web Capture. Make sure that your browser supports ActiveX controls, that you have enabled them, and that you have installed the Web Capture ActiveX control."

It works fine on a XP computer with Office 2003 and Office 2003 web components installed, but I won’t have the luxury of having a second laptop next to me all the time. I’ve added my domain name to local Intranet and all ActiveX is enabled. I cannot however find the Web Capture ActiveX control online to install it. It is included in the 2003 web components but does not work with office 2007. Does anyone have a bandage or know how to fix this issue entirely?
  • 0




    New Member

  • Member
  • Pip
  • 1 posts
Cannot create or modify Web Capture. Make sure that your browser supports ActiveX controls, that you have enabled them, and that you have installed Web Capture ActiveX control.

Clicking the create button calls the WC_EditWebCapture() function
The WC_EditWebCapture() function in turn calls the client dependant Microsoft.WebCapture Searching the registry for Microsoft.WebCapture on an upgraded O12 or clean install O12 machine does not return any results; the needed registry key is removed in the upgrade and not installed on the O12 installation
The registry keys have been specifically removed from the client registry settings
WebCapture using a client side activeX control for that button.
The STSTPKPL.EXE (and the Web Parts contained in it) has been deprecated for O12. As such, controls such as the standalone Web Query ActiveX control do not ship in the O12 box - you need to use O11 in order to edit a web part that uses this control. It should be that if you have O11 and O12 installed side-by-side (not an upgrade, not a clean O12 install) that this continues to work b/c you will still have the control installed as part of O11.
Now all above related to the activities happening in the background when you click on create of the web capture web part. Which means it is known issue with office 2007

Problem resolved on 3 machines by having any of office 2003 component installed with office 2007.
We tested on 3 machines.
First machine have office 2007 + project 2003
Second machine Office 2007 + Front page 2003
Third machine Office 2007 + Excel 2003
Activity Summary :
- we made sure the steps in the article applied and the component installed.
- we installed front page 2003 with office 2007
- result: web capture worked fine
- office 2007 and project 2007 problem persists
- office 2007 and excel 2003 result: working fine
- office 2007 and project 2003 worked fine
- we tried to backup O11 registry keys and removed all office 2003 component and have office 2007 only
- same result
- we should have at least 1 office 2003 component installed.
Related Knowledge Base Articles
- Workaround is named in KB929320;

• Adding the Office 2003 Web Parts and Components add-in to a Windows SharePoint Services 3.0 server should be used as a temporary workaround only.
• The Office 2003 Web Parts and Components add-in requires that the client computer that will modify the Web parts have either Office 2003 client applications or the Office 2003 Office Web Components add-in installed. Before you upgrade client computers to the 2007 Office system, phase out the Office 2003 Web Parts and Components add-in, and use alternative solutions. The client components for the Web parts that are included in Office 2003 are not included in the 2007 Office system.

Additional Information and Recommendations
Infos regarding "Web Capture Web Part":
see OfficeQFE.18674 RFC - SPS2003/MOSS2007 Gradual Upgrade - Web Capture web part fails after installing MOSS binaries
  • 0



    New Member

  • Member
  • Pip
  • 3 posts
SharePoint 2007: Web Capture Web Part

If you have experience with SharePoint 2003, you are most probably in love with the Web Capture Web Part.

To install this Web Part on WSS 3.0 you need to fiddle around a little. You can't just download the Office Web Parts and Component from MS, because it will complain that you need WSS 2.0 installed to be able to install the file..
  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP