Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Slow Startup Qs on Bootvis & Prefetching...


  • Please log in to reply

#1
elkatbal

elkatbal

    Member

  • Member
  • PipPip
  • 21 posts
I've downloaded and used Bootvis and am extremely happy that it lowered my startup time from 209 seconds all the way down to 89 seconds.

but when analyzing the data, I noticed that although my start up takes less time, all the different areas were less time except my pretching. that takes almost a minute to boot. that's two thirds of the total start up time. all the other bootvis results I've seen from other people's computers has their prefetch time down around ten seconds or so, mine's six times that!

I've read that tweaking and/or deleting your prefetch files is highly discouraged so I'm wondering if there is anything I can do to lower my prefetch start up time without doing any damage to my system.

thanks!!
  • 0

Advertisements


#2
Ztruker

Ztruker

    Member 5k

  • Technician
  • 7,065 posts
I've been running with prefetch disabled for a year or more now. Try it for yourself and see if it helps or hinders your boot time and system performance.

Click on Start then Run, type regedit and press Enter or click OK.
Navigate to:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\PrefetchParameters\EnablePrefetcher]


Set the value to 0 (zero)
Reboot

To restore, set the value to 3.

Thinking about this, I think I'll turn it on again for awhile and see what it does for me :)
  • 0

#3
elkatbal

elkatbal

    Member

  • Topic Starter
  • Member
  • PipPip
  • 21 posts
interesting development...

I turned prefetching off (set value to zero) and ran another BootVis test and prefetching actually took longer and the total startup time is now back up over a hundred seconds with prefetch taking 90 seconds. does the time reduce with more reboots or should I turn it back on?

it seems that every time I restart my laptop, the boot time is completely random, sometimes really super slow, sometimes just slow but never fast!

thanks!
  • 0

#4
Ztruker

Ztruker

    Member 5k

  • Technician
  • 7,065 posts
I turned mine back on (set it to 3) and could see no difference in boot time. Normal system performance does seem a bit improved though.

Have you tried emptying your prefetch folder and letting it repopulate via normal use? I have this tip squirreled away:

A little known tweak that can help you gain some performance on your XP Professional (and Windows Server 2003) related systems is to periodically empty the prefetch folder. The prefetch folder is used to help speed up the loading of programs; XP will load programs it thinks you need before you ask for them yourself.

http://www.windowsne...refetch-XP.html
  • 0

#5
elkatbal

elkatbal

    Member

  • Topic Starter
  • Member
  • PipPip
  • 21 posts
I've heard clearing your prefetch files to speed up boot time is a MYTH and to never do it because of possible long-term damage to your system.

I just don't understand when I have prefetch turned off, it's still taking a minute and a half for prefetch to load. makes no sense.

any input?

thanks!
  • 0

#6
Ztruker

Ztruker

    Member 5k

  • Technician
  • 7,065 posts
I don't see any way clearing the prefetch folder is going to damage your system. Agreed it probably doesn't buy you much but it won't cause you any harm either.

No idea why boot is taking a minute and a half to load the prefetch stuff at any time, for any reason. Were I you,I would disable prefetch, then empty the prefetch folder, then re-enable prefetch.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP