Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

nVidia GeForce 7600 GS Driver issue

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 1 posts
I'm having a very frustrating problem. My geforce 7600 is acting totally crappy. I've been working on this for several months. One day, unexpectedly, my screen started to flicker and lost signal. So then I uninstalled the driver. I got signal back. Then I re-installed the driver and lost signal again. All of my drivers are up to date. The only video card active at the time was the 7600 GS. I would greatly appreciate any help I can get. Thank you very much!!
  • 0





  • Member
  • PipPipPip
  • 424 posts
Try the card in another system. If it works fine then there could be a compatibility issue with something on your computer.

If it does the same thing then its just a bad card or a bad driver (contact the manufacturer).
  • 0

The Admiral

The Admiral

    Trusted Tech

  • Technician
  • 1,067 posts
Also reinstall your chipset drivers. :)

Or, System Restore FTW.

Edited by The Admiral, 26 February 2008 - 04:21 PM.

  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP