Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

USB 2.0


  • Please log in to reply

#1
jits

jits

    Member

  • Member
  • PipPip
  • 11 posts
Hey guys i cant get my computer to use usb 2.0. it always gives me a balloon saying this device can perform faster if i connect them to a high speed 2.0 port. All off these ports on my computer should be 2.0, but for some reason its not. How can i or where can i download the current drivers for usb 2.0 here is some info on my computer:

okay here is some more info on my computer:
The Ice Cube IC-VL67 is a barebones SFF PC system that measures 8.3 x 9.5 x 12 in. It features a socket 478 motherboard (Intel 845PE chipset, 2 184-pin SDRAM DIMM, 1 AGP 4x slot, 1 PCI slot), 220W PSU, 1 5.25" drive bay, and 2 3.5" drive bays (1 hidden).
Motherboard Features
- Socket 478 Motherboard Model: CF-EG65
- Intel 82865G + ICH5 chipsets
- Support up to 2 GB DDR400/333 DIMMs
- Integrated Graphics controller in 865G GMCH
- Support extent AGP 8X slot
- AC-Link with AC'97 compliant audio
- Realtek RTL8100BL 10/100 Base-T Ethernet controller
- Full Duplex supported, WFM 2.0 Compliant
- Serial ATA port
  • 0

Advertisements


#2
Neil Jones

Neil Jones

    Member 5k

  • Member
  • PipPipPipPipPipPipPipPip
  • 8,476 posts
Full USB 2 functionality was added in XP Service Pack 1.
You do have XP service pack 1 or later?
Alternatively this may be an option in the BIOS, in some cases most boards default to USB 1.1 speeds unless you tell them otherwise.
  • 0

#3
happyrock

happyrock

    Tech Moderator

  • Retired Staff
  • 9,285 posts
check your bios...make sure usb hi speed is enabled
  • 0

#4
jits

jits

    Member

  • Topic Starter
  • Member
  • PipPip
  • 11 posts
im running xp w/ SP2. i also checked my bios, it doesn't give me an option for USB 2.0 or high speed. Maybe i need to download some updated usb drivers?
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP