Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Display Properties Won't Open When Wallpaper Enabled


  • Please log in to reply

#1
Sarah Jane Smith

Sarah Jane Smith

    Member

  • Member
  • PipPip
  • 46 posts
I have a strange problem. I couldn't open display properties. When I tried to open it, it would sometimes flash on the screen for a split second and I narrowed it down to the wallpaper setting. Safe mode does not use Wallpaper. If I delete the Wallpaper value in Hkey_Current_User\Control Panel\Desktop then display properties will open. However, I am not able to change the background or add wallpaper. When I click on any item on the wallpaper tab, display properties disappears. I can set wallpaper by opening an image in internet explorer, right-clicking on it and selecting set as background. However, this recreactes the Wallpaper key and display properties will no longer open. Does anyone have a clue how I can get my display properties working properly? I do not think the applet is damaged, because it works in safe mode. Also, I have tried several copies of desk.cpl that I have my computer and they all have the same affect. There are also no group policies that prohibit changing the wallpaper. I have been working on this for two days straight now and am at my wits end. If anyone has any ideas, please let me know. Oh yes, as far as I know I am virus and malware free. I have AVG and I even ran smit fraud removal tool and combofix just to make sure. It made know difference. Please Help.

--Sarah Jane Smith
  • 0

Advertisements


#2
Sarah Jane Smith

Sarah Jane Smith

    Member

  • Topic Starter
  • Member
  • PipPip
  • 46 posts
One more thing, I am running XP pro and recently added a Nvidia GForce 6 series video card. I have tried uninstalling the drivers, disabling it in the device manager and running in VGA mode, all with no affect. I have also tried 2 different Nvida drivers.
  • 0

#3
Ztruker

Ztruker

    Member 5k

  • Technician
  • 7,065 posts
Since it works in Safe Mode, try this:

First, physically disconnect from the Internet to prevent a malware infection while your Anti-virus and/or Firewall are disabled in the following steps, then do a normal boot:

Click on Start then Run, type msconfig and press Enter.
Click on the Startup tab and disable everything (I mean everything).
Do a regular boot, see if it runs normal.
If yes then use msconfig to enable several items at a time till you find the culprit.

If no, click on the Services tab. Check the Hide All Microsoft Services box then click the Disable All button.
Again, do a regular boot, see if it runs normal.
If yes then use msconfig to enable services till you find the culprit.

Once you've found the culprit, uninstall it or find out how to eliminate it from your system. Simply disabling it in msconfig is a temporary fix at best.

Reconnect to the Internet when your AV and firewall are active again.
  • 0

#4
Sarah Jane Smith

Sarah Jane Smith

    Member

  • Topic Starter
  • Member
  • PipPip
  • 46 posts
I've already tried running it in diagnostic mode with no affect. I also tried disabling all hardware drivers in the device manager while in diagnostic mode, including the graphics driver. The only thing that helps even is a little is is deleting the Wallpaper value in the registry. Safe mode doesn't use wallpaper. Deleting this value and thus disabling wallpaper allows the display properties windows to open, but it is only partially functional. I am unable to change the background color and when I try to change the wallpaper, the window disappears. I'm pretty sure the problem started after I installed the video drivers for my Nvidia Geforce 6 series graphics card. I have tried uninstalling the drivers and disabling them with no affect. I think that the software must have changed some kind of system setting or something. The strange thing is that the same card and drivers works perfectly in another XP Pro computer that I have in the house.
  • 0

#5
Sarah Jane Smith

Sarah Jane Smith

    Member

  • Topic Starter
  • Member
  • PipPip
  • 46 posts
I thought disabling add-ons had helped and I wrote this. It turned out it was merely a co-incindence. See my later posts for the actual solution.

"I finally got the solution from the Microsoft forum, so I thought I would share it with everyone. The problem was being caused by a bad internet explorer add-on. I disabled all add-ons, restarted internet explorer, logged off of windows and logged back on and it worked. I then re-enabled the add-ons I wanted to keep and it's still working. Thank you to those who offered advice. I am grateful that I finally found a solution. I thought I was going to be stuck with this annoying malfunction forever. --Sarah Jane Smith"

Edited by Sarah Jane Smith, 24 February 2008 - 07:44 PM.

  • 0

#6
Ztruker

Ztruker

    Member 5k

  • Technician
  • 7,065 posts
Thanks Sarah. Sometimes I forget how tightly integrated IE is with the XP Operating System.
  • 0

#7
Sarah Jane Smith

Sarah Jane Smith

    Member

  • Topic Starter
  • Member
  • PipPip
  • 46 posts

Thanks Sarah. Sometimes I forget how tightly integrated IE is with the XP Operating System.


Actually, upon further research I found that the Internet Explorer add-ons had nothing to do with it. The fact that I disabled them was a mere coincidence. What happened was, for some reason, it stopped working as suddenly as it started working. I couldn't reproduce the events that caused it to work in the first place. Finally, I found some advice on another board that indicated a malfunctioning display properties could be caused by an extra tab added by some third party utility software. I knew for a fact that Nvidia had added an MSI tab. I looked up how to uninstall the tab. I deleted the msicpl.dll file located in the windows\system32 folder. This fixed it. I no longer have an MSI tab and my display properties is working perfectly. I am finally a happy camper after days of trying to fix this issue. Thank you so much to everyone who tried to help me with this problem. --Sarah Jane Smith
  • 0

#8
Sarah Jane Smith

Sarah Jane Smith

    Member

  • Topic Starter
  • Member
  • PipPip
  • 46 posts
I also think this fix from Microsoft might have been helpful. I will never be able to try it though because I have already solved the problem another way. For future reference, here is the link to the article. http://support.microsoft.com/kb/317128
  • 0

#9
Ztruker

Ztruker

    Member 5k

  • Technician
  • 7,065 posts
Yup, I believe you're right. ShellExView might have given us a clue if I'd thought of it.

Thanks for the update. I've added all the info you posted to my Tips databaase so hopefully I can help someone in the future.

Edited by Ztruker, 24 February 2008 - 07:49 PM.

  • 0

#10
Sarah Jane Smith

Sarah Jane Smith

    Member

  • Topic Starter
  • Member
  • PipPip
  • 46 posts

Yup, I believe you're right. ShellExView might have given us a clue if I'd thought of it.

Thanks for the update. I've added all the info you posted to my Tips databaase so hopefully I can help someone in the future.

I actually tried some kind of shell extension viewer and disabled all non-microsoft shell extensions. It didn't help. Nothing worked until I deleted the msicpl.dll file as referenced in my previous post.

By the way, thank you so much for all of your input. I hope that my struggles will help someone else. --Sarah Jane Smith
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP