Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Two problems


  • Please log in to reply

#1
Seltox

Seltox

    Member

  • Member
  • PipPipPip
  • 254 posts
My hdd is an 80GB SATA drive and is setup like so:

C: - 4.88GB. Windows XP Pro SP2 is installed here.
D: - 68.9GB. This is were everything else is meant to go.
E: - 704MB. Windows 98SE is installed here.

Okay, first. The default location for things to install is C:\Program Files, I want to change this to D:\Program Files. With almost all installs you can change the install location, but I couldn't manage to do so with Windows Live Messenger. Even though it's only a small program, I still don't want it on the C:. Can I change the default install location so that D:\Program Files is the base place?

Second. I don't really _ever_ use 98SE, but I still want it to be there. Is there a way I can 'hide' the Partition so it isn't accessable through XP, and can I remove it from the boot selection screen? Everytime I startup my PC, I have to select XP professional - it's a bit tiresome.

Thanks, Seltox.

Edited by Seltox, 20 February 2008 - 12:17 AM.

  • 0

Advertisements


#2
pip22

pip22

    Trusted Tech

  • Banned
  • PipPipPipPipPip
  • 2,663 posts
Can't help with the WLM problem as I don't use any such software, but if you want to avoid having to select which OS to boot every time, you can do it by editing the 'boot.ini' file. Instructions here: http://support.microsoft.com/kb/289022

Or simply set XP as the default operating system (using the same applet as above) if it isn't already. Then XP will load without waiting for any user input.

If you want the 98SE volume to be 'invisible' to Windows Explorer, My Computer etc, you can achieve that with the 'TweakUI' Powertoy from Microsoft.
Get it here: http://windowsxp.mvps.org/tweakui.htm (choose v2.10 for SP1 or later). When installed, open it. In the left pane, expand 'My Computer' then click 'Drives'. Now any drive letter you untick in the right-pane will be rendered invisible in Explorer and dialog-boxes (click 'Apply' or 'OK' of course). The unticked drives will remain invisible even when Windows is restarted, until you decide to make them visible again.

Edited by pip22, 20 February 2008 - 09:12 AM.

  • 0

#3
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,019 posts
  • MVP
for the default install change read This (note...these instructions involve modifying your registry, which can be dangerous...be sure to back up your registry before making changes)

for the "boot menu changes"
open up "my computer" click on tools then folder options, click the "view" tab, check the box for "show hidden files" and uncheck the box for "hide protected system files" press ok and apply untill you're back at the "my computer" window....open the C drive and look for a file called "boot.ini" open it and copy the contents of that file here with your next post (i'll tell you what to remove)

for hiding the 98 drive in XP read this. i suggest using the TweakUi method
  • 0

#4
Seltox

Seltox

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 254 posts
Thanks for the replies :)

I'll get onto this in a few hours once school is over. I'll let you know how I go.
  • 0

#5
Seltox

Seltox

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 254 posts
Okay! I hid the 98SE partition and changed the default install directory (havn't tested it yet, but it should have worked).

Here's my boot.ini

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect /NoExecute=OptIn
C:\="Microsoft Windows"


  • 0

#6
Seltox

Seltox

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 254 posts
I removed it via command prompt using bootcfg /delete /ID 2.

Booted up XP Pro straight away, strangely though my mouse wasn't working afterwards (I have a Razer Copperhead gaming mouse). I plugged it into a USB on my case and it worked though.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP