Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Trouble with a WorkGroup


  • Please log in to reply

#1
Hoibie

Hoibie

    New Member

  • Member
  • Pip
  • 6 posts
Hi. Three XP machines - all at SP2 - fully updated. One machine (let's call it #1) won't behave.
I establish it in the workgroup using the XP wizard. It sets up the workgroup name under Microsoft Windows Networks. I see it there on #1 - big as day. I click on it and it reveals all three machines. So far so good.
But
After a while - maybe all day maybe several days - I lose access to the workgroup on #1. It won't stay or "stick". When this happens I get the now infamous "Workgroup not accessable. You might not have permission.... etc. etc." Strangely, I still have access to the other machine's shares. And because of this not being able to stick the shares on #1 no longer flow through to #2 or #3. I have to keep re-running the wizard to reset everything. It's OK for a while then back in the dumper...

Anybody know how to make the workgroup establish in a way that makes it "stick" so I don't have to keep running the foolish wizard, over and over???

Thanks.
  • 0

Advertisements


#2
hfcg

hfcg

    The hippie freak computer geek

  • Member
  • PipPipPipPipPip
  • 2,496 posts
Hello, and welcome to Geeks To Go.
Could you tell me what Firewall(s) are in use?
Do you use the same firewall on all the machines?
Please check the security levels on any security programs that you are using.
  • 0

#3
The Skeptic

The Skeptic

    Trusted Tech

  • Technician
  • 4,075 posts
When the workgroup name is lost, what is the new name that you see. Is it always the same?
  • 0

#4
Hoibie

Hoibie

    New Member

  • Topic Starter
  • Member
  • Pip
  • 6 posts
OK, thanks to both of you for your offer of help....

All machines running Eset's NOD32 Internet Security Suite which includes a software firewall, anti-everything, virus protection, etc. Again, I don't want to belabor a point but when I run the wizard on #1 and reboot (because that's what I always do when changing an important setting), the WorkGroup always appears and comes back strong. Something somewhere is knocking it offline (if that's the right term) only after some time passes.

When the failure occurs and I rerun the wizard, the workgroup name is always MSHOME which I am instructed by others to change to another value. I believe this is because in this wireless world a lot of people leave their wireless routers unprotected, set at the default and subject to enumerating systems that surround them.

Anyway, right now, after a wizard and reboot about 5 hours ago, it's still working. This is one of those little "annoyances" that Windows users often face when just trying to get something simple accomplished...

Any other thoughts or ideas?

Thanks, people!
  • 0

#5
hfcg

hfcg

    The hippie freak computer geek

  • Member
  • PipPipPipPipPip
  • 2,496 posts

Strangely, I still have access to the other machine's shares. And because of this not being able to stick the shares on #1 no longer flow through to #2 or #3. I have to keep re-running the wizard to reset everything. It's OK for a while then back in the dumper...

You are able to access the other machines, so you are still connected to the workgroup.
Your security software may be hiding the machine from view.
It is blocking the other two machines from accessing the computer.
  • 0

#6
The Skeptic

The Skeptic

    Trusted Tech

  • Technician
  • 4,075 posts
I don't know what causes the name of the workgroup to reset to MSHOME. However, I would try to set all the computers on MSHOME workgroup and enable the WEP protection in the the router. The encrypted password set in WEP is a far stronger protection then the name of the workgroup. Also, make sure that the firewall in the router is enabled.
  • 0

#7
hfcg

hfcg

    The hippie freak computer geek

  • Member
  • PipPipPipPipPip
  • 2,496 posts

I don't know what causes the name of the workgroup to reset to MSHOME.

I think that he meant the name reset after he ran the setup wizard again.

Edited by hfcg, 25 February 2008 - 04:38 AM.

  • 0

#8
The Skeptic

The Skeptic

    Trusted Tech

  • Technician
  • 4,075 posts
My idea is to avoid the wizard in the first place. If the subscriber leaves the computer on MSHOME (the default workgroup) and set the other computers to MSHOME, then the problem may be avoided. I am not sure if this will succeed but since I can't find a better solution it may be worthwhile trying. As far as security is concerned I don't think it will make any difference If a password is encrypted in the router.
  • 0

#9
Hoibie

Hoibie

    New Member

  • Topic Starter
  • Member
  • Pip
  • 6 posts
OK folks thanks for the tips. I could have been a little more clear - let me try again. (BTW - this morning I came across the same problem again...)

When the problem occurs, there's no error notice or other indication that something's gone wrong. All I know is I can't use the shares I created. I re-run the wizard. At the point the workgroup name comes up, XP always puts out the default workgroup name of MSHOME and I believe that is an expected result of the wizard's operation. OK, I set that string to GILES like I want it. I reboot. It comes back up and is working fine with the name that I set. Everything works fine until at some unknown point and for some unknown reason, the name I pick gets squished. When that happens, I can open Explorer, drill down through Network Places > Entire Network > Microsoft Windows Network > GILES (my chosen name). It's still shows up there but when clicked it takes 30 seconds or more for the hourglass to extinguish and then tells me GILES as "not accessable". I run the wizard, reboot and...well, you know the story - it works for a while and drops out maybe in a day maybe in several days. It accepts the name I want, but it's having trouble "sticking".

One thing I haven't done which I will do is review the Event Logs! There might be a clue there! Let me clear them out and let the system run until I hit the wall again.

Any other suggestions you good people have would be appreciated while I work through this.

Edited by Hoibie, 25 February 2008 - 12:21 PM.

  • 0

#10
Hoibie

Hoibie

    New Member

  • Topic Starter
  • Member
  • Pip
  • 6 posts
OK, here we go. I have some hints to look at. I've had a good 2.5 days with machine #1. It was working so well I thought maybe it'd taken care of itself. Nay, this morning I came to machine 2 to try and find machine 1 and it's not home. I went to machine 1 - the problem machine. Let me see if I can describe the symptom further:

I went to Explorer and drilled down through Network Places > Entire Network > Microsoft Windows Network. When I click on Microsoft Windows Network, the computer takes a bit of time to put the workgroup name up. Incidentally, when working properly, clicking on this responds immediately. During the wait, an hourglass appears as though it's searching. Eventually, when the workgroup appears, I click on it and after a bit more waiting and hourglassing, "Workgroup not accessable...". Now, right after I went to search for machine #1 on machine #1 (not a typo - It should be able to search and find itself). Lo and behold the search window shows machine #1, and it's located right under the workgroup name, like you'd expect, with all it's shares! But if I run over (in that same explorer window) and click on workgroup... wait...wait...wait... "Workgroup not accessable..." Isn't this funny? A search for machine #1 on machine #2 will pull up machine #1 and shows it under the workgroup. But click on the workgroup (machine #2, now...) and it only displays machine #2.

If you're thinking firewall, I have to point out that this worked perfectly for a solid 2+ days with the firewall in place.

I said I would review the event log. I went to bed last night and all was working. Got up and it's dead. Nothing in Applications. Now -- See the attachment from the System log showing a "semiphore" warning from the DHCP server. Is this it?

Attached Thumbnails

  • WkGpProblem_1.jpg

Edited by Hoibie, 28 February 2008 - 10:37 AM.

  • 0

#11
**Brian**

**Brian**

    Semper Paratus: Always Ready

  • Member
  • PipPipPipPip
  • 1,159 posts
Just a quick Question:

Are You allowing all PC's to communicate with Each other through the firewalls???

I have had issues with my network dying out sometimes. It may be that your router is attempting to renew its address, and failing. I have had 3 machines on my net, one (this machine I am typing on) has an address of xxx.xxx.x.47, one had an address of xxx.xxx.x.46, the third had an address of xxx.xxx.x.45.

What I did was to allow communication with *.46 and *.45, by telling it what addresses had permission to communicate with each other. If the firewall is instructed to allow traffic from *.45 *.46 and *.47, and the internal IP stays the same on the router, this should take care of the issue, because the firewalls know what addresses to allow communication from - This way, regardless of whether there is a renewal of the IP, the network should theoretically work.

Of course, if there is one Firewall that is not allowing traffic into the system, then it can cause errors that say that you don't have permission to access the network.

I am not sure what your eventlogs show, but this is what I have done to eliminate workgroup issues, however, I have not seen a workgroup change like you have described.

I am on Verizon, and this setup worked for me :)

Good Luck - Hope this may help :)

Brian

Edited by **Brian**, 28 February 2008 - 11:35 AM.

  • 0

#12
hfcg

hfcg

    The hippie freak computer geek

  • Member
  • PipPipPipPipPip
  • 2,496 posts
This sounds like each of the computers firewall is blocking the other computers.
Please allow access from all of the machines on the network, or disable the firewall.
  • 0

#13
Hoibie

Hoibie

    New Member

  • Topic Starter
  • Member
  • Pip
  • 6 posts
Actually I have allowed all communication to occur to and through all firewalls on each computer. Am using NOD32 Home Security Suite. Again, I hate to belabor a point but these systems work fine through each firewall for the first couple of days. Sometimes it'll go a little longer, sometimes shorter. I think if it were a firewall problem, it would occur right off - immediately from the get go - but it doesn't. All I have to do is run the wizard, reboot machine #1 and all is well. This tells me something else is going wrong, as the system runs.

I'm looking at this DHCP issue as the culprit because generally at night all systems are just on and running with no one playing with them. I'm guessing but does anybody know how to set up a more permanent link to DHCP? What I think I'll do is keep the logs running from now when it's working and see what happens next time it fails and try to correspond the two events if they come together.

I just rebooted a minute ago, to release the problem I've had all day and >poof< all systems work fine through, from and to each the firewall that is in operation. But I know what'll happen a day or so down the line. Machine #1 will lose its grip and I'm into re-running the wizard, rebooting and we're back to normal.

Is this maybe a serivice that's being stopped or something in the background that's suddently halted. Isn't there some sort of "persistent" command that's used in the "NET USE" command structure??

Thanks, y'all...
  • 0

#14
The Skeptic

The Skeptic

    Trusted Tech

  • Technician
  • 4,075 posts
Try to give each computer a fixed address and disable the DHCP option in the router. To create a fixed address click on Network connections in Control Panel. Click on the connection icon, choose properties, mark Internet Protocol (tcp/ip), click properties and fill up the required data.

Before that you have to create a small home or office network, giving all the computers the same workgroup name but different computer names.

If you need more guidance please let us know.
  • 0

#15
Hoibie

Hoibie

    New Member

  • Topic Starter
  • Member
  • Pip
  • 6 posts
Hi again. I think hfcq has the answer because....

Try as I might, I thought I had machine #1's firewall set up properly. The way I had it setup was in "transparent" mode, meaning I didn't want to see warnings/alerts/messages from it. When I set it up, I instructed it to "Allow File Sharing Across Networks". After poking and prodding around, I decided to tell the firewall to give me the warnings/alerts/messages just so I could see what might be happening. Indeed it told me a lot about what's happening on my network including calls to the other machines!!! And, I saw a block - what the..??? So, I dug deeper into the configuration (they really bury it) and found, lo and behold, the swtich for File Sharing turned off!!! How and why, who knows perhaps the firewall had some problem it didn't tell me about and reconfigured iteself to the more rigorous setting. (Pure guess). Anyway, I re-set it to Share Across Network and I'm happy to report I'm on my 3rd day of errorless ops. At least now I know where to look. And thank you all for your indulgences....

Edited by Hoibie, 21 March 2008 - 08:51 AM.

  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP