Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Starcraft Graphic Problems


  • Please log in to reply

#1
Mr. Jack

Mr. Jack

    Member

  • Member
  • PipPip
  • 92 posts
I have an Nvidia GeForce 8600 GT, and when I start up Starcraft, the screen is all blocky and flashing really fast. Even in-game. I couldn't get a screenshot because it looks normal in the screenshot.

I tried re-installing my gfx card drivers, but it didn't help. I tried messing with the compatibility options in the exe properties, but that didn't help either.

Any other suggestions?
  • 0

Advertisements


#2
Gstayton

Gstayton

    New Member

  • Member
  • Pip
  • 2 posts
I am running into the exact same problem, and the upper lefthand corner is blocked out... I am searching franticly to find a fix for this... Im running Windows XP Pro and have an Nvidia 8500, with latest drivers...
  • 0

#3
lvleteor

lvleteor

    New Member

  • Member
  • Pip
  • 4 posts
I have the same problem but with an 8800GT Nvidia gpu. It's obvious it has something to do with the GPU since when the card is disabled with a reboot, Starcraft runs fine. When card is enabled with compatibility for starcraft set to 640x480 and 256bit colors (the native resolution for Starcraft) it won't work and I get the black blocks with running lines everywhere. Someone has to have an answer for this =(. I upgrade my comp and can't play my 2nd all-time fav game StArCrAfT. We might just have to wait for Starcraft 2 ? ? ? ? ?
  • 0

#4
lvleteor

lvleteor

    New Member

  • Member
  • Pip
  • 4 posts
SO .. after all this time of searching for an answer I have come up with only 1 way to run starcraft without getting the black boxes/lines. The ONLY way I can figure out to run Starcraft is mentioned above. If you are running Windows XP: Go to the control panel>System>Hardware>Device Manager>and manually disable your video card under the tab "Display Adapters". This will require a reboot and run windows at a very low res but at least you can play Starcraft! Good luck finding a better solution but until now this is all I can tell you guys out there.
  • 0

#5
Gstayton

Gstayton

    New Member

  • Member
  • Pip
  • 2 posts
If your not to keen on disabling your drivers, or are just like me and hate rebooting (Yay for me) then you could try and shut down just about everything, cause from my trials, if I shut down Xfire, Steam, and anything else that tried to play on top of Starcraft, it ran fine, untill Mcaffee told me there was an update... then I had the same issue and had to restart Starcraft, so it seems like its an overlay issue...
  • 0

#6
Snake45

Snake45

    New Member

  • Member
  • Pip
  • 1 posts
it appears to be an issue with xfire's in-game chat
if you are useing it
go into its option settings and under game find starcraft and disable the in-game chat, and restart your computer.

it atleast worked for me. oh and if you have other issues with games try disabling xfire it seems to fix issues in select games
  • 0

#7
lvleteor

lvleteor

    New Member

  • Member
  • Pip
  • 4 posts
Yea i do run Xfire... as well as msn messenger. .. I'll try that but if not disabling video card works 100%... Happy gaming fellow geeks :)
  • 0

#8
HappyGeek

HappyGeek

    New Member

  • Member
  • Pip
  • 1 posts
I have the 8600GT and do not have this problem for starcraft BUT.. It happens on my counter strike, warcraft 3, Quake 4, Quake 3, Soldier Front, Urban Terror, Tremulous. I either get a runtime error after playing for 1-30 minutes or a physical memory dump. If I run the program after the runtime error, it will allow me to play a little bit more but then it crashes. Also, if I do anything else before I play, like going online, it will flash on my screen and be really laggy by dropping my fps down to 1 when I play the game. I tried going to the task manager and set the affinity to cpu 0 or 1(I have a dual core) and it helps a little bit by letting me play longer than 30 minutes but it will crash. They say it has something to do with dual core and nvidia geforce cards being incompatible.
  • 0

#9
lvleteor

lvleteor

    New Member

  • Member
  • Pip
  • 4 posts
WEll it IS Xfire for the Starcraft Issue. I exited Xfire to where it doesn't run at all and can now run Starcraft with no troubles at all. Thanks guys! Disabling graphics card was a waste of time. again thanks
Cheers!
lvleteor
  • 0

#10
t.holmes

t.holmes

    New Member

  • Member
  • Pip
  • 1 posts

it appears to be an issue with xfire's in-game chat
if you are useing it
go into its option settings and under game find starcraft and disable the in-game chat, and restart your computer.

it atleast worked for me. oh and if you have other issues with games try disabling xfire it seems to fix issues in select games



This is the solution for this problem. I looked at multiple forums and tried multiple "fixes" but nothing worked until I came to this post". Disabling xfire in-game chat will fix the flashing black boxes and lines.
  • 0

#11
ZEUS_GB

ZEUS_GB

    There's no school like old school!

  • Retired Staff
  • 1,650 posts

it appears to be an issue with xfire's in-game chat
if you are useing it
go into its option settings and under game find starcraft and disable the in-game chat, and restart your computer.

it atleast worked for me. oh and if you have other issues with games try disabling xfire it seems to fix issues in select games



This is the solution for this problem. I looked at multiple forums and tried multiple "fixes" but nothing worked until I came to this post". Disabling xfire in-game chat will fix the flashing black boxes and lines.


Hi t.holmes and welcome to G2G!

Good to know, thanks for the post.

Edited by ZEUS_GB, 16 May 2010 - 05:26 AM.

  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP