Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

USB ports non-responsive for any wireless mouse


  • Please log in to reply

#1
Lori R.

Lori R.

    New Member

  • Member
  • Pip
  • 2 posts
I am using a Toshiba Satellite Pro, A200 with Windows XP SP2 installed. It has 4 USB ports (2 on each side). I like to use a wireless mouse, but suddenly the laptop will not accept any wireless mouse. I have tried the various wireless mice on other computers, and they work fine, so I know the problem is not the mouse itself. When I plug in the USB stick for the mouse, it's as if nothing happened. No light, no blinking, nothing. I have gone to the Device Manager, no yellow exclamation marks. I have uninstalled all USB controllers and Root Hubs, and they have reinstalled, to no avail. I have run Registry Editor, which found some problems of various kinds, but nothing that fixed this problem.

I can use a USB wired mouse (Logitech) on two of the four ports, but the two righthand ones do not work for anything. I can also use a USB microphone on the left side, but it seems to be a bit picky and needs to be unplugged and replugged in if left sitting.

I have turned off the power management feature in the Root Hubs.

I am fairly confident about doing stuff on my computer *if* I have the steps to follow, so suggest away!

Edited Sunday Mar 2:
I have updated the bios on the laptop to no avail. I am surprised that I have not had one person suggest anything yet? I'm starting to think this must be a hardware problem....

Edited again SUnday Mar 2:
No responses at all???

Edited by Lori R., 03 March 2008 - 01:01 AM.

  • 0

Advertisements







Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP