Jump to content

Welcome to Geeks to Go - Register now for FREE
Geeks To Go is a helpful hub, where thousands of friendly volunteers serve up answers and support. Get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message and all ads will be removed once you have signed in.
Create an Account Login to Account

Won't let me install ANY fonts AT ALL


  • Please log in to reply

#1
wynnyelle

wynnyelle

    Member

  • Member
  • PipPipPip
  • 116 posts
I need to install a whole bunch of fonts to create some Proboards skin sets. I downloaded Abaddon font from 1001freefonts.com and no matter what I try it won't let me install the font. I tried downloading it directly to the Fonts folder, won't let me. I tried downloading it to another folder and extracting it to Font, won't let me. I tried extracting it to a different folder and then moving it into the Fonts folder, won't let me.

What am I doing wrong?
  • 0

Advertisement


#2
The Admiral

The Admiral

    Trusted Tech

  • Technician
  • 1,067 posts

won't let me

What won't let you?
I just copied all my fonts from my Windows.old to my C:/WINDOWS/Fonts folder, and everything worked great. Can you give any more details on what you are doing and what you see?
  • 0

#3
wynnyelle

wynnyelle

    Member

  • Member
  • PipPipPip
  • 116 posts
I keep trying to drag and drop the new fonts into the Fonts folder and it just ends up not being there at all, no matter what I do. I don't see anything. Nothing really changes.
  • 0

#4
Murray S.

Murray S.

    Trusted Tech

  • Member
  • PipPipPipPipPipPipPip
  • 4,513 posts
  • MVP
Howdy:

You can't just drag and drop new fonts into the Fonts folder. You have to install them.

Go into the Control Panel and open the Fonts Folder.

Now, click on File and select "Install New Font".

Point the request to the folder you downloaded the font to. (Follow the prompts).

Murray
  • 0

#5
wynnyelle

wynnyelle

    Member

  • Member
  • PipPipPip
  • 116 posts

Now, click on File and select "Install New Font".


Where is "File"? I don't see it anywhere.
  • 0

#6
Murray S.

Murray S.

    Trusted Tech

  • Member
  • PipPipPipPipPipPipPip
  • 4,513 posts
  • MVP
It should be along the top of the Windows screen.

If it isn't there, can you see the "Tools" option to the upper right side of the screen?

Murray
  • 0

#7
wynnyelle

wynnyelle

    Member

  • Member
  • PipPipPip
  • 116 posts
No, there's just "Organise"--and under that, things like Cut, Copy, Paste, etc.

Well, "Organise" and "Views." "Views" just gives you the option of changing the icon sizes in the window.

Does this board allow you to post screencaps? If you do maybe tomorrow I'll get you one of the window, if you think it'd be useful. Maybe then it'll be easier for you guys to steer me in the right direction. Thanks for keeping on this, btw.

Edited by wynnyelle, 05 March 2008 - 10:44 PM.

  • 0

#8
Murray S.

Murray S.

    Trusted Tech

  • Member
  • PipPipPipPipPipPipPip
  • 4,513 posts
  • MVP
Click on "View" and then on the "Toolbar" option that should show up.

If it does, click on "Menu Bar"

Murray
  • 0

#9
wynnyelle

wynnyelle

    Member

  • Member
  • PipPipPip
  • 116 posts
There is no Toolbar option on "Views." Just six different icon size options.
  • 0

#10
Murray S.

Murray S.

    Trusted Tech

  • Member
  • PipPipPipPipPipPipPip
  • 4,513 posts
  • MVP
Okay.. over to the right of the Vews/Organize, can you see a question mark?

If you can, click on it. I get an option for an explanation on "How to install a font"..

Murray
  • 0
<

Advertisement


#11
wynnyelle

wynnyelle

    Member

  • Member
  • PipPipPip
  • 116 posts
It says click File, and then click Install new Fonts.

But where is File???
  • 0

#12
wannabe1

wannabe1

    Tech Staff

  • Technician
  • 16,645 posts
Click on "Organize", point to "Layout", and click on "Menu Bar". Then you'll see the "File" option.
  • 0

#13
wynnyelle

wynnyelle

    Member

  • Member
  • PipPipPip
  • 116 posts
All right I did what you said and it said that it installed the font. But when i went into the Fonts folder to make sure that it was there, it was not there. Do I have to wait a while for it to appear?
  • 0

#14
vogelgeist

vogelgeist

    New Member

  • Member
  • Pip
  • 3 posts
Just an update, because I was having the EXACT same issue.

So I couldn't drag-and-drop like I used to with XP. I have to kinda go in a very backwards way to do it, but it works.

Step One: Open up the .zip folder.
Step Two: Place the .ttf on your desktop or some other folder.
Step Three: Right click and hit "Install", it'll automatically route to the Font folder. If you have the font folder open, hit the "Back" button, and then go forward.

Tada! Your font will be there. :3

In the meanwhile... I gotta beat up Photoshop for -not- showing me my font...
  • 1

#15
Jasondnga

Jasondnga

    New Member

  • Member
  • Pip
  • 1 posts
THANKS A TON!!! The desktop trick solved the problem in no time. Its weird since I never had problems installing fonts until just recently.
  • 0

Advertisement




Similar Topics: Won't let me install ANY fonts AT ALL     x


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

featured