Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Blank Screen after dell logo loads.


  • Please log in to reply

#1
chipy100

chipy100

    New Member

  • Member
  • Pip
  • 4 posts
Greetings geekstogo.

I have a problem that might have to do with hardware. I have a year old Dell e1705 laptop and it was working fine the other day. I than tried turning it on and all I get is a black screen after the dell logo appears. I can't even get onto safe mode. I pressed f8 numerous times to no avail. I than tried to reinstall the windows xp but it doesn't work either. After I get to the "Please press anything to startup windows xp cd" it does not work. Does anyone know what the problem might be? :)
  • 0

Advertisements


#2
The Admiral

The Admiral

    Trusted Tech

  • Technician
  • 1,067 posts
Try plugging in an external monitor to see if the problem continues. It could be three things - the video driver, the video card, or the LCD screen. Let's find out which. :)
  • 0

#3
chipy100

chipy100

    New Member

  • Topic Starter
  • Member
  • Pip
  • 4 posts

Try plugging in an external monitor to see if the problem continues. It could be three things - the video driver, the video card, or the LCD screen. Let's find out which. :)



Thing is I don't know how to plug an external monitor. But if the dell logo shows up and I can get on bios, won't that rule out the lcd problem? Thanks for replying. :)
  • 0

#4
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,019 posts
  • MVP

Try plugging in an external monitor to see if the problem continues. It could be three things - the video driver, the video card, or the LCD screen. Let's find out which. :)



Thing is I don't know how to plug an external monitor. But if the dell logo shows up and I can get on bios, won't that rule out the lcd problem? Thanks for replying. :)

you're correct i'd assume it's not the LCD screen since you can see SOMETHING on the screen...so basically as soon as you get past anything related to POST (which is where you bios info shows up and the dell splash screen shows up) the screen goes black (including the safemode prompts if you press F8)?
  • 0

#5
suprgirl6

suprgirl6

    New Member

  • Member
  • Pip
  • 1 posts
I'm having the exact same problem, the only dif. is that my dell came with vista premium.
Can't go pass the Dell logo, if i enter in f12 or f8 I don't get the option for safemode.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP