Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Internet....Weird?


  • Please log in to reply

#1
zea

zea

    New Member

  • Member
  • Pip
  • 4 posts
Hey, I have a broadband connection shared between two pcs by a d-link 604 router. On my one pc, the internet is fine...but on this pc it takes about 20 seconds to load google for the first time..then ill click on a link and it doenst work. Saying "Page cant be displayed" THen i click it again, same thing. Then clicking it a 3rd or 4th time it works. This happens with all sites, and some sites take about 30 seconds to load. I have nothing downloading, and i just reformatted today and there is no spyware, viruses, or adware. I have reset the router, renewed IP, and tried this pc with the other one off. This even happened right before the reformat also. Any ideas? Thanks (I hope this submits).


-Z
  • 0

Advertisements


#2
gerryf

gerryf

    Retired Staff

  • Retired Staff
  • 11,365 posts
latest drivers from the manufacturer website?
  • 0

#3
Murray S.

Murray S.

    Trusted Tech

  • Member
  • PipPipPipPipPipPipPip
  • 4,513 posts
  • MVP
Howdy:

Try this Microsoft fix..

Error Message: The Page Cannot Be Displayed

Murray
  • 0

#4
zea

zea

    New Member

  • Topic Starter
  • Member
  • Pip
  • 4 posts
Yes I have the latest drivers. Thanks for that microsoft link though, I'm trying it now.

-Z
  • 0

#5
zea

zea

    New Member

  • Topic Starter
  • Member
  • Pip
  • 4 posts
Nope, none of those soultions worked. Thats for people who have NO internet. I have internet, it just seems to time out randomly withought giving errors, and then it comes back fully working till i try to access another link.


-Z
  • 0

#6
zea

zea

    New Member

  • Topic Starter
  • Member
  • Pip
  • 4 posts
Any other suggestions?


-Z
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP