Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

PSU fans not working


  • Please log in to reply

#1
unstablefears

unstablefears

    Member

  • Member
  • PipPip
  • 38 posts
Hi,

I have a Ultra X-Infinity 600 power supply. I just recently noticed that both the inside and outside fans are not working correctly. I checked all connectors, removed everything and put it back together, removed the dust, etc. The fans still won't work. My CPU fan and an extra fan I have on the tower work fine.

I don't know how long both PSU fans have not been working, I just noticed when my graphics card ( ATI X1950 Pro ) popped up a thermal warning so I decided to check all my fans.

Is it normal for both PSU fans to not run? I thought it would only be normal for one of them not to be.

Anyone have any insight on this? Would I need to purchase another PSU? I just got this one about 7 - 8 months ago....

Thanks.
  • 0

Advertisements


#2
Neil Jones

Neil Jones

    Member 5k

  • Member
  • PipPipPipPipPipPipPipPip
  • 8,476 posts
If the fans are definitely not spinning and they're not clogged up with dust, and its still under warranty, use it and have it replaced.
  • 0

#3
unstablefears

unstablefears

    Member

  • Topic Starter
  • Member
  • PipPip
  • 38 posts
Thanks, that is what I thought as well, but was hoping not lol. As I can't locate the warranty so will need to purchase one out right.

My computer is still running fine, from what I can tell. I downloaded SpeedFan and every temp is running around 60*C except for the core, which is around 30*C. Just curious if these temps are fine to keep it running daily until I get a new PSU? Also, would a 500W PSU work fine for my current specs ( they are in my signature )? Kinda low on cash :).
  • 0

#4
Titan8990

Titan8990

    Member

  • Member
  • PipPipPipPipPip
  • 2,189 posts
I wouldn't recommend keeping your system running because it is likely underpowering your system ATM, not to mention the PSU could blow at any time w/o proper cooling. This would make since as video cards that are not receiving enough power tend to overheat. You should be fine with a 500w power supply but I suggest getting a higher quality brand than Ultra.

Edited by Titan8990, 27 March 2008 - 12:05 PM.

  • 0

#5
unstablefears

unstablefears

    Member

  • Topic Starter
  • Member
  • PipPip
  • 38 posts
Thanks. Do you know of any better quality brands then Ultra? I am going off of TigerDirect ( or NCIX if needed ). Any suggestions for a 500W PSU that is good quality at a good price? :).
  • 0

#6
Titan8990

Titan8990

    Member

  • Member
  • PipPipPipPipPip
  • 2,189 posts
This is the cheapest I could find: http://www.ncix.com/...facture=MUSHKIN

Seems you all pay a bit more in Canada then we do here in the U.S.. If you don't mind a mail-in rebate you can get this for cheaper but the Mushkin is a higher quality PSU: http://www.ncix.com/.....CZ Technology

Edited by Titan8990, 27 March 2008 - 12:39 PM.

  • 0

#7
unstablefears

unstablefears

    Member

  • Topic Starter
  • Member
  • PipPip
  • 38 posts
Thanks, the Mushkin looks really good. I also was looking for a PSU that allowed me to remove unwanted cables, so that works out perfect. Thank you! :)
  • 0

#8
Titan8990

Titan8990

    Member

  • Member
  • PipPipPipPipPip
  • 2,189 posts

I also was looking for a PSU that allowed me to remove unwanted cables, so that works out perfect.


The term for this is "modular".

Happy to help :).
  • 0

#9
unstablefears

unstablefears

    Member

  • Topic Starter
  • Member
  • PipPip
  • 38 posts
Heh, thanks :). Just ordered it with Express Shipping. Can't wait to get it in there. It looks pretty big, though it says it is ATX supported.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP