Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Motorala SB5120 cable modem problem


  • Please log in to reply

#1
aquarius012273

aquarius012273

    Member

  • Member
  • PipPip
  • 21 posts
I have broadband cable internet connection from Comcast, who gave me a Motorala SB5120 modem. It works fine when connected directly to my laptop computer (Vista Home Premium) using an ethernet cable. When I sought to put a wireless router in between, all [bleep] broke loose.

The router is a Netgear Wireless N RangeMax Dual band router, capable of sending signal at 2.4GHz and 5 GHz simultaneously, and offers many different types of encryption including WEP, WPA-PSK, WPA2-PSK (AES) and a combination of the latter two. Since my Vaio laptop is capable of receiving signals at 5GHz, I chose that option to receive interference free signals, and the option of multiple channels to choose from.

The signal flow is such: Cable --> SB5120 --ethernet cable---> Netgear --ethernet cable---> laptop;
Or after configuration: Cable --> SB5120 --ethernet cable---> Netgear -- wireless -- laptop.

The problem is occurring in both these scenarios, wired and wireless connection between the router and my laptop. Even after successful connection, where the Netgear Router has cloned the laptop's MAC address, it is receiving the proper IP from cable modem, the cable modem disconnects every 15-30 minutes on its own, and then reconnects after about 5-10 seconds. All the lights go off except the PC activity light, and then start coming back one at a time from top to bottom. This is the exact same situation as normally happens if the power to the modem is cut and then restored.

As a result, I am getting very slow speed of connection to almost any web page. As long as the modem remains operational, the webpage load fine, but once it starts to disconnect at regular intervals, the pages slow down to a crawl and then the browsers don't load any page any more, until the modem comes back up.

When I completely disconnected the Netgear router from the equation, and connected just the modem to the computer as before, I had no problem getting on the internet and staying connected. Can someone please offer some constructive suggestions about my problem? Has any one else encountered anything like this before?
  • 0

Advertisements


#2
NetRanger

NetRanger

    New Member

  • Member
  • Pip
  • 2 posts
Are you using model WNDR3300? If so... do you have the latest firmare for that router? Firmware Version 1.0.14 fixes a lot of various problems:

Fixed Intel Centrino 4965AGN client, WNDA3100 client low throughput problem at 5GHz
Fixed various WPS issue
Changed Router Status page display: if WAN is Static IP and WAN link is down, show IP address, subnet mask, etc as 0.0.0.0
Avoid PADI traffic storm when multiple pppoe clients exist in the same network and no PPPoE server is present
Fix UPnP parse uncompleted packet
Support DHCP client for rfc3442
Fixed Setup Wizard cannot detect PPPoE connection if router is configured as PPTP mode.
Fixed Setup Wizard cannot detect PPTP connection if router is configured Foxconn Confidential 2 as PPPoE mode.
Fixed Reserved IP table blank device name issue
Fixed incorrect timestamp format in email log report
Fixed the Refresh function of QoS GUI page: remove disconnected LAN / WLAN clients from MAC table when Refresh is pressed
Block multicast / broadcast MAC address in QoS page
Fixed blank state wizard cannot display special characters correctly
Fix some Port triggering GUI issues
Block invalid subnet mask for LAN IP setup
Block invalid MAC address in Wireless ACL list
Disable spanning tree by default. Enable spanning tree only in wireless repeating mode.
Log displays wrong error messages.
Router treats TCP UPnP port mapping as TCP/UDP.
Fixed NAT v2.5.0.44 cause some port conflict issues.
Port triggering range can not be triggered correctly
The source port has not been mapped to the same port
Port forwarding can work before reboot DUT when detects existed ALG session.
Router can't deal with conflict Remote Management and port triggering service.

Log in to the router at http://192.168.1.1, and check the firmware version.
  • 0

#3
aquarius012273

aquarius012273

    Member

  • Topic Starter
  • Member
  • PipPip
  • 21 posts
Exactly right. That is what I am using. When I was setting up the router, it automatically did a firmware check and update. I am not sure if it ran through properly. Thank you for the suggestion. I shall check.

I have earlier worked with a variety of wired or wireless routers, linksys, netgear, and belkin. I confess that I have not worked with a cable modem before, because wherever I was, at home or at work, the internet connection from a T1 or T3 LAN (from the School) always came through a wall jack, and that was it. Plugged into the router, it just worked after the basic configuration. This is the first time that I am having to deal with a cable modem.

Anyway, UPDATE: I reconnected the modem to the router with an ethernet cable, as before, and switched on the wireless of my computer, again as before, and I find now everything is working in perfect order! Go figure! I have not had a single instance of modem restarting for over 22h now!!

UPDATE ON UPDATE: I still have no clue why this happened in the first place, since it works now without my changing any single setting!!
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP