Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Outlook 2007 autocomplete not working


  • Please log in to reply

#1
Diego8

Diego8

    Member

  • Member
  • PipPipPip
  • 189 posts
My computer runs Windows XP Home and Office 2007, including Outlook 2007. In Outlook, the autocomplete function empties every time Outlook is shut down; i.e every time it's restarted, it doesn't "remember" any addresses when filling the "To" field.
The most common solution I could find suggested that the nk2 file that stores the addresses was corrupted, and that we should shut down Outlook, find the nk2 file; rename it; then open Outlook and hopefully it would create a new nk2 file that wasn't corrupted and would "remember" entries.
The trouble is, there is no nk2 file at all. I've run a search of the entire C drive and it finds no file with the nk2 extension. I've also made sure that the autocomplete function is turned on in the Outlook settings.
Can anyone help? Would a reinstallation of Office 2007 solve the problem?

Any help is greatly appreciated.

Edited by Diego8, 28 March 2008 - 04:17 PM.

  • 0

Advertisements


#2
pip22

pip22

    Trusted Tech

  • Banned
  • PipPipPipPipPip
  • 2,663 posts
Outlook.nk2 may be a hidden or system file, so unless the 'Search' tool is configured to include these types of files, it won't be found even when it exists.

First ensure the autocomplete feature is enabled in Outlook. Close Outlook.

Open the 'Search' tool and click "All files and Folders".

Click "More Advanced Options" and tick all three search options which are in bold type.

Now type outlook.nk2 in the top search bar.

When found, right-click->delete.

Close the 'Search' tool.

Re-open Outlook.

Edited by pip22, 29 March 2008 - 06:54 AM.

  • 0

#3
Diego8

Diego8

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 189 posts
I have checked that autocomplete is enabled in Outlook and that hidden or system files are being shown. I've run a search again for outlook.nk2 and it didn't find that file. Googling a little bit i found that the path of the nk2 file is C:\Document & Settings\%USERPROFILE%\Application Data\Microsoft\Outlook. I explored that folder and confirmed that the nk2 file does not exists.
I have also tryed copying the outlook.nk2 file from another computer (Outlook's autocomplete works fine in it) but it didn't work.
  • 0

#4
Diego8

Diego8

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 189 posts
Finally i could solve the problem but i had to take extreme measures. I uninstalled Microsoft Office and installed it again. Now Outlook's autocomplete is working fine.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP