Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Unreadable external hard drive/iPod. Unable to format, ideas?


  • Please log in to reply

#1
tazical

tazical

    Member

  • Member
  • PipPip
  • 14 posts
Hi all,

I hope someone can help with an extremely annoying hard drive problem. A few weeks ago the logic board on my 80GB 5th Generation iPod Video broke- it was completely dead with nothing whatsoever on screen and no hard drive noises, so I'm fairly sure that the logic board was the only thing broken and the hard drive was alright at that point.

I replaced the logic board with a different second-hand one, and the hard drive is now spinning up fine, the iPod is recognised when connected to a PC or laptop, but I am unable to access the drive itself. The iPod appears to be stuck in disk mode/safe mode, and a message is on screen saying 'Connect to your computer. Use iTunes to restore.' When I plug it into iTunes it states that it has found an iPod in recovery mode and restores the factory settings, but as soon as it finishes the restore the same message appears again and it loops over and over,

The iPod was partitioned 50/50 for use as both a music player and an external hard drive. I'm not fussed about retrieving the files that were on there, as everything was backed up beforehand. My main concern is just to get the drive accessible again as I suspect that some of the operating files or partitions may have got messed up either when the board failed or when iTunes has tried to restore it.

I tried to reformat, however, disk management tells me that Removable Drive G is unreadable. If I right-click on Drive G in My Computer the laptop thinks for A Very Long Time before offering me a menu, but nothing happens when I click on format. When I check the properties for the drive it's listed as Apple iPod USB Device, Location: 0, Capacity 0MB. I suspect that possibly I need to try and reinstall the partitions or create new ones for the drive to be readable but I'm not sure if that is the case, or how to do it.

Alternatively is it possible that the replacement logic board is at fault rather than the hard drive? It passed though a few hands to get to me, and wasn't tested/needed by the person I bought it from so there's no way of knowing for sure that I haven't been extremely unlucky and had two duff ones. I'm inclined to think this is not the case, since the device is being recognised by the laptop and iTunes as an iPod, but they just don't seem to know what to do with it.

Does anyone have either a solution to this, or recommendations of programs I can run that can solve this issue? Any help would be appreciated, as I have no idea where else to look for answers!

Edited by tazical, 02 April 2008 - 04:19 PM.

  • 0

Advertisements







Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP