Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Mouse not working in XP DOS for game


  • Please log in to reply

#1
Mozman

Mozman

    New Member

  • Member
  • Pip
  • 5 posts
OK I play an old Championship Manager game which was orginally meant for Windows 95/98 but I have played it on XP machines for many years.

Anyway, on my latest self-built machine, the mouse will not work in DOS when I start the game. This has been a problem for the last 12 months but now im determined to solve it as I really want to play the game.

The game works perfectly on my old XP machine with the mouse absolutely fine so is there anything that I can copy over from it to make the mouse work on this machine? Ive tried downloading DOS drivers and all the stuff but nothing has worked. I understand it might be to do with adding something in the Autoexec but I dont dont know where that is and nothing has come up on a search.

Any help would be extremely appreciated on this.
  • 0

Advertisements


#2
Sarah Jane Smith

Sarah Jane Smith

    Member

  • Member
  • PipPip
  • 46 posts
I found This Page which addresses the issue. It even includes a convenient link to download a dos driver. Go down to where it says, "I want a mouse in dos" Yes, you may need to edit the autexec file. Dos no longer uses autoexec.bat, it uses autoexec.nt . It is located in the c:windows\system32 folder. In order to see it, you may need to go to tools folder options in windows explorer. Go to the view tab and enable "show hidden files and folders" and ucheck the "hide system files and folders" box. Open the autoexec.nt file in notepad to edit it. Make sure you save you work. I think you just need to ad a line that says c:\mouse.com if you use the mouse.com driver and put it in the root directory. But look over the instructions on the link I sent you for other ideas. You can also compare the autoexec.nt file on your old computer to your new one. I also found anoter site where someoe claimed he could only get the mouse to work in full screen mode. So try running your program in full screen mode (box in upper right-hand corner of window) if you haven't already. I hope this helps. --Sarah Jane Smith
  • 0

#3
Mozman

Mozman

    New Member

  • Topic Starter
  • Member
  • Pip
  • 5 posts
*Sigh*

Thanks very much for your help Sarah but im no closer to getting this working :)

Ive also found something else out, I put in an old DOS game to install and it starts with you having to select which game, in dos, you would like to install.

But the keyboard wasnt working either, it works fine in Command-Prompt, but when actually in proper DOS, neither the keyboard or the mouse work.

Arghhh!!!
  • 0

#4
Sarah Jane Smith

Sarah Jane Smith

    Member

  • Member
  • PipPip
  • 46 posts
Just a thought. Are your keyboard and mouse ps-2 or usb? I do not think dos will ever recognize a usb mouse or keyboard. Also, can take the mouse and keyboard from your old computer and see if they work in dos mode on the new one. Make sure you shut down you computer first. You should never install a PS-2 device with your computer powered on. It will not work and may fry your motherboard.
  • 0

#5
Mozman

Mozman

    New Member

  • Topic Starter
  • Member
  • Pip
  • 5 posts

Just a thought. Are your keyboard and mouse ps-2 or usb? I do not think dos will ever recognize a usb mouse or keyboard. Also, can take the mouse and keyboard from your old computer and see if they work in dos mode on the new one. Make sure you shut down you computer first. You should never install a PS-2 device with your computer powered on. It will not work and may fry your motherboard.


Ok both my mouse and keyboard are in PS/2 ports but they both do not work in DOS proper.

Im guessing this is something to do with BIOS settings?

My Mobo is an ASUS M2N-E.

Any ideas? :) :)
  • 0

#6
Sarah Jane Smith

Sarah Jane Smith

    Member

  • Member
  • PipPip
  • 46 posts
I'm not sure if Bios has anything to do with it. However, at least once source I found suggested that you could change a setting in bios that has to do with a usb mouse or keyboard. Make sure you select save and exit when you leave bios (usually F10). One person even suggested a bios update might help. However, these types of updates are risky and if anything goes wrong they can fry your motherboard. Another person suggested that reinstalling windows would help. I think that might be like cutting off the head to cure a headache.

Other than that, I would like to know what have you tried so far. Did you dowload the mouse driver I linked you too? If so, what directories did you put it in? Did you make any edits to autoexec.nt If so, what does it look like? Have you tried running the program in full screen mode? Have you tried a differnt mouse and keyboard (just for grins)? What you might have to figure out is what makes it work on your old computer. What is the difference in how they are set up?
  • 0

#7
Mozman

Mozman

    New Member

  • Topic Starter
  • Member
  • Pip
  • 5 posts

I'm not sure if Bios has anything to do with it. However, at least once source I found suggested that you could change a setting in bios that has to do with a usb mouse or keyboard. Make sure you select save and exit when you leave bios (usually F10). One person even suggested a bios update might help. However, these types of updates are risky and if anything goes wrong they can fry your motherboard.


I have tried turning off USB legacy, USB Control but with no luck. I havent tried a BIOS update yet.

Another person suggested that reinstalling windows would help. I think that might be like cutting off the head to cure a headache.


I have reinstalled Windows maybe 4 times in the last year and its never worked for this problem.

Other than that, I would like to know what have you tried so far. Did you dowload the mouse driver I linked you too?


Yes, I tried 3 different ones.

If so, what directories did you put it in?


I put mouse.com and mouse.exe in C:\ and C:\windows

Did you make any edits to autoexec.nt If so, what does it look like?



Yes I added mouse.com and I can see it run that command right before the game starts.

C:\mouse.com
mouse.com

@echo off

REM AUTOEXEC.BAT is not used to initialize the MS-DOS environment.
REM AUTOEXEC.NT is used to initialize the MS-DOS environment unless a
REM different startup file is specified in an application's PIF.

REM Install CD ROM extensions
lh %SystemRoot%\system32\mscdexnt.exe

REM Install network redirector (load before dosx.exe)
lh %SystemRoot%\system32\redir

REM Install DPMI support
lh %SystemRoot%\system32\dosx

REM The following line enables Sound Blaster 2.0 support on NTVDM.
REM The command for setting the BLASTER environment is as follows:
REM	SET BLASTER=A220 I5 D1 P330
REM	where:
REM		A	specifies the sound blaster's base I/O port
REM		I	specifies the interrupt request line
REM		D	specifies the 8-bit DMA channel
REM		P	specifies the MPU-401 base I/O port
REM		T	specifies the type of sound blaster card
REM				 1 - Sound Blaster 1.5
REM				 2 - Sound Blaster Pro I
REM				 3 - Sound Blaster 2.0
REM				 4 - Sound Blaster Pro II
REM				 6 - SOund Blaster 16/AWE 32/32/64
REM
REM	The default value is A220 I5 D1 T3 and P330.  If any of the switches is
REM	left unspecified, the default value will be used. (NOTE, since all the
REM	ports are virtualized, the information provided here does not have to
REM	match the real hardware setting.)  NTVDM supports Sound Blaster 2.0 only.
REM	The T switch must be set to 3, if specified.
SET BLASTER=A220 I5 D1 P330 T3

REM To disable the sound blaster 2.0 support on NTVDM, specify an invalid
REM SB base I/O port address.  For example:
REM	SET BLASTER=A0

I tried the mouse.com at the start and end of the autoexec file.

Have you tried running the program in full screen mode?



It ONLY runs in full-screen mode, there's no way (that I know) to make it run in a window. Its always been that way this game.

Have you tried a differnt mouse and keyboard (just for grins)?


Yes.

What you might have to figure out is what makes it work on your old computer. What is the difference in how they are set up?


The old PC specs are...

XP Home
MSI KT3V Mobo
Athlon 2600+
1GB Ram

My PC is...

XP Home
ASUS M2N-E Mobo
Athlon X2 5400+
3GB RAM

The old PC was bought from a shop but has a new mobo (same as the old), new RAM and a new GFX card. It worked before the mods and still works now.

The new PC is self-built but it has never worked on this PC.
  • 0

#8
Sarah Jane Smith

Sarah Jane Smith

    Member

  • Member
  • PipPip
  • 46 posts
It sounds like you've tried everything but the bios update. Have you tried loading optimized defaults in bios? It's worth a shot. Also, I don't think it will make any difference, but it looks like you've loaded the mouse driver twice in autoexec.nt Honestly, since you've already reinstalled windows a few times, I doubt tweaking windows will make much difference. The bios update option is seeming more like it might be worth a try. As a final thought, I guess you could turn usb legacy and usb control back on and try a usb mouse and keyboard.
  • 0

#9
stettybet0

stettybet0

    Trusted Tech

  • Technician
  • 2,579 posts
How are you running DOS on an XP machine (which is based on NT, not DOS)? Command prompt on XP is not the same thing as DOS. Try downloading and using DOSBox, which is a free DOS emulator.
  • 0

#10
Sarah Jane Smith

Sarah Jane Smith

    Member

  • Member
  • PipPip
  • 46 posts
[quote name='stettybet0' date='Apr 17 2008, 06:00 PM' post='1216640']
How are you running DOS on an XP machine (which is based on NT, not DOS)? Command prompt on XP is not the same thing as DOS. Try downloading and using DOSBox, which is a free DOS emulator.
[/quot

You are right that XP doesn't technically have DOS. However, it does simulate DOS for the sake of running older programs. The odd thing is that it was working on his old computer using Windows XP DOS simultion only. I do like the idea of downloading a DOS emulator though. It would certainly be an easy solution. I would recommend trying that before risking a bios update for sure. I just wish I had thought of it!
  • 0

#11
Mozman

Mozman

    New Member

  • Topic Starter
  • Member
  • Pip
  • 5 posts
Absolutely fantastic!!

The DosBox works a treat, you can even window it which ive never seen before on this game!!

I set the config of DosBox to auto load this game so when double clicking on DosBox it auto opens my game in full-screen, just as it used to on my old PC with the 'proper' launch exe!!

Its been so long since ive played the game as well and its finally working on this PC :) :) :)

Thanks so much for your help, I guess the original problem remains unsolved but it doesnt matter now :)

Sarah and Stetty :) :) :)
  • 0

#12
Sarah Jane Smith

Sarah Jane Smith

    Member

  • Member
  • PipPip
  • 46 posts
Awesome, Mozman! I'm glad you got it working! :)
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP