Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Changing Default Program for Opening Audio Files


  • Please log in to reply

#1
McKnight

McKnight

    Member

  • Member
  • PipPip
  • 92 posts
Hello all...

I am using Windows XP - Media Center and would like to be able to change the default program that is used to open audio files (CDs).

As of right now I have been going to Control Panel>Appearance and Themes>Folder Options, where I am shown extension types (including Audio CDs); but this folder type does not show anything under "Opens with." I tried using the advance menu to input an action... either play or open; and then give an application in which to work off of (iTunes is what I want). However, when I apply and exit out of my changes... and then put in a CD, nothing happens at all.

I want iTunes to open automatically (not autoplay) when ANY audio CD is inserted. What would I do to change iTunes to be my default player; not only for iTunes, but in the computer as well?

Thank you very much...
  • 0

Advertisements


#2
cmpm

cmpm

    Member

  • Member
  • PipPipPip
  • 561 posts
Right click the file you want to play and it will have the 'open with' command there. Then you can select 'choose program', you can choose the program you want and check the 'always' box if you want to also. If you choose the always box that type of file will always open with the program you selected.
  • 0

#3
McKnight

McKnight

    Member

  • Topic Starter
  • Member
  • PipPip
  • 92 posts
Thank you...

So, to sum it up: there is no option under control panel to change these settings? It is best to insert an audio cd and then right click the extension from the my computer>d drive folder?

*Also, I don't want the cd to play... just open the appropriate application (iTunes in this case); I believe the cd will autoplay using your method... is there a way to turn this off?

Thanks again...

Edited by McKnight, 21 April 2008 - 10:39 AM.

  • 0

#4
cmpm

cmpm

    Member

  • Member
  • PipPipPip
  • 561 posts
Well.....

if the files are set to play in itunes
see what happens when you insert the disk

i don't think you can set the cd to open a program without it playing---for music anyway

open my computer and right click the cd drive and you can tell it what to do from those options in the auto play tab

you might be able to set itunes to not play when it opens
and keep the autoplay on instead of turn it off
if you turn it off it won't do anything when you put a cd in
  • 0

#5
McKnight

McKnight

    Member

  • Topic Starter
  • Member
  • PipPip
  • 92 posts
Thank you very much...

I have one more question for you if I may:

What exactly are the Folder Options>File Types under the Control Panel? It lists audio CDs (with no extension), and gives an option to change what it does (i.e. Play, Open, etc.); however, I deleted these actions and am not sure if I messed up something by doing this.

When I add a new Action and new application to apply it to; it does not do anything. Are these options changed automatically when I do what you recommened with autoplay, etc.?

Thanks again... sorry for my confusion.
  • 0

#6
cmpm

cmpm

    Member

  • Member
  • PipPipPip
  • 561 posts

When I add a new Action and new application to apply it to; it does not do anything. Are these options changed automatically when I do what you recommened with autoplay, etc.?


Ok, I'm not sure what you are saying you did and what you are asking here.

Right now I have to go to work so I'll pick it up tomorrow if someone else doesn't.

Please rephrase and say specifically what you did and what you are asking.

In my post I just suggested a solution. Thanks.
  • 0

#7
McKnight

McKnight

    Member

  • Topic Starter
  • Member
  • PipPip
  • 92 posts
Thank you...

I did the following:

Start>Control Panel>Folder Options>File Types (tab), which gives a list of registered file types. From here I found the Audio CD (extension), which was at the top for me. When highlighted, the "Details" of this drive were blank (bottom). So, I then clicked the "Advanced" button, which brought me to a place to edit the actions and applications used for those actions (i.e. Open with iTunes). I removed the default action that I saw, which was PLAY (I do not remember the application that was originally used). Now, when I create a new action and then pick a desired application to perform this action, it does not work (i.e. do the action I requested). It makes me feel that these actions may be code specific (i.e. HTML, Java, etc.)

Did I screw something up?

*Also, there are so many different methods to change the default audio options (The one I just mentioned, going to Start>Set Program Access and Defaults, and the one you mentioned about Right clicking the file; which one takes control?*

Thanks again...

Edited by McKnight, 21 April 2008 - 12:00 PM.

  • 0

#8
cmpm

cmpm

    Member

  • Member
  • PipPipPip
  • 561 posts
Alright, the only time I have used the Folder Options/File types was to unassociate a file type to get my 'open with' command back in right clicking a file. This has happened a couple of times. But not a lot.

Have you tried setting the files to open with (by right clicking the file type) itunes and inserted the cd and see what happens?

Post the results when you are ready. Also see if you can set itunes to not autoplay and just open as you are wanting it to do I believe.
  • 0

#9
McKnight

McKnight

    Member

  • Topic Starter
  • Member
  • PipPip
  • 92 posts
Thanks again for your help... I am a bit meticulous (OCD if you will); therefore, it comforts me to have as much as possible where it is supposed to be, and doing what it should:

With that in mind... I went through many applications/extensions/etc. to sort them out. I figured out that my method (Editing file types), is a way to creat short-cuts as you described (i.e. by right-clicking... Bolding the words "Open/Play/Etc."). Also, these are short cuts for any extension (type) that you want... which will also specify which application is used to do what you want; and belive me... I went through a lot... lol.

But to sum up the indiscretion of changing the program for opening audio files; it was as simple as right-clicking on the D drive (as you stated), clicking on the Auto Play tab, and then picking from the options (Media Files, Audio CD files, Video files, etc.). On the Audio CD drop-down, the answer was "Show files with iTunes." Therefore, when I now insert a CD, iTunes opens but does not play the cd; also, I specified in iTunes (probably pointless as I did it in the D drive) to ask for import (which it only does if iTunes is already open before inserting the Audio CD).

It was as simple as that... my process did teach me a lot about extensions/file types, but essentially was only a way to narrow down the exactness of an Audio CD (i.e. which program opens MP3 files, MP4 files, etc.).

*ALSO, to answer your question about right-clicking a file type: it seemed as if this setting was only saved for that individual file, not for every one of the same extension. Therefore, by editing the file extensions I was able to keep file types grouped and thus the settings as well. In addition, the only harm with deleting an extension/action is that if a file needed to use that extension/action, it will state that the type is not specified and prompts the user to look for a way to open the file (as most people have probably seen before).

I appreciate your patience and help with my confusions. Thanks a bunch...

Edited by McKnight, 22 April 2008 - 02:11 PM.

  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP