Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

USB Drive Trouble


  • Please log in to reply

#1
erroldee

erroldee

    New Member

  • Member
  • Pip
  • 2 posts
I just bought this new 240GB USB Drive. The Computer detects it as Ameco USB Drive

I was having trouble using because when i transfer some files into it, sometimes the file works but most of the time i get a fractured file.
and when i create a folder directly into the drive sometimes i get some files inside consisting of "A" "Y" and some other weird characters.
I am not able to delete this files and when i do Error checking the folder is converted to a file and i can delete that.

I tried to Reformat it to FAT32 or NTFS and all i get is an error message saying that the format cannot be completed.
I have this friend that tried to format it on MAC and it worked. He formatted it to FAT32.

As i was using it (in Windows), the problem with the folder creation disappeared but the file transfer problem is the same.

As i was reading some solutions i came to a forum that was saying that i should try to divide it to 32GB partitions.
I had my friend divide it to 7 32GB and 1 16GB partition in his MAC. in the middle of creating those partitions his computer just stopped responding and everything froze. so we had no option but to restart the Mac. After that we tried to redo the partitioning but now it can't be detected. i tried to plug it in to Windows and i can still see it in Device Manager and in the Safely Remove Hardware Section but doesn't show any drive assignment. I tried using KillDisk or the Windows Disk Management but it just goes to Not Responding.

Need help badly. Thanks.

Edited by erroldee, 25 April 2008 - 05:18 AM.

  • 0

Advertisements


#2
erroldee

erroldee

    New Member

  • Topic Starter
  • Member
  • Pip
  • 2 posts
can anybody help me please?
  • 0

#3
shaked889

shaked889

    New Member

  • Member
  • Pip
  • 1 posts
i have the same problem...
does anyone know how to solve it?
i work with xp.
thanx
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP