Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Remote Desktop with multiple computers


  • Please log in to reply

#1
user659

user659

    New Member

  • Member
  • Pip
  • 3 posts
I have 3 pc's (one Vista and 2 XP's) on my home network, connected by a D-Link DI-624 Router. Lets call them
compa, compb and compc.I have set up Remote Desktop and can use RDC to control any of the PC's from any other
as long as I enter their pcname or local IP address (eg. 192.168.0.xxx) in the RDC box.
That works fine.

I have a DDNS account that gives me a fixed domain DSN (eg. *.network.dyns.cx) so that I can connect remotely
to any of the PC's by entering the internet IP address (rather than a local one) in an RDC connection box.
In my D-Link Virtual Server (VS) setup I set compa to port 3389 (the "official" RDC port for Windows). I set up
compb to 3388 and compc to 3387.

If I use RDC to remotely connect to compa and thus enter compa.network.dyns.cx in an RDC box, I connect, as expected,
to compa. That's great! But if I enter compb.network.dyns.cx, I still connect to compa.
if I enter compc.network.dyns.cx, I still connect to compa.

I cannot enter *.network.dyns.cx as an IP address. That's invalid. I have to replace the * with a valid
computer name that I have set up in the D-link VS list. As mentioned above, if I use the compa computer name, that
is accepted and I'm "ported" by 3389 to compa. What's clear is that if I use the other computer names as the prefix,
the D-Link does see them as valid computer names but the port chosen is not the one in the VS list. 3389 seems to
override the port number in the list. Of note, when I do use compb.network.dyns.cx, but get connected instead to compa,
the small box at the top of the RDC screen erroneously says I'm connected to compb.network.dyns.cx.

I read the Microsoft Article 306759 that describes how to change the listening port for Remote Desktop.
OK, I figured I would change the listening port on compb to 3388 and did that via Regedit, as the article described.
I also entered a new REMOTE DESKTOP entry in the Windows Firewall exceptions and assigned it 3388. Of interest, I
first tried to merely edit the official REMOTE DESKTOP entry in the Firewall but found that "edit" would not change the
port number from 3389. It appears to be "hard coded". Anyway, I then entered compb.network.dyns.cx:3388 as outlined
in Article 304304 but the connection was denied. Removing the :3388 suffix only put me back into the pickle of connecting
again to compa. 3389 rules again!

So, why does Microsoft tell us how to change the RDC Port number but Windows won't pay attention to the change? I was hoping that I
could set 3388 to compb and 3387 to compc.

I'd love some help.

However, please don't bother telling me about the workaround, namely that one can daisy-chain RDC requests. Indeed, that's
a nice workaround. For those who don't quite understand, the procedure is to RDC to the one computer, say compa that will work with
an Internet IP. Then, with RDC controlling compa, issue an RDC using the local computername compc (or it's 192.168.0.xxx IP address).
You now can remotely control compb.


Thanks for any help,

User659

PS. I've used phony computer names above for security reasons.

Edited by user659, 05 May 2008 - 09:09 PM.

  • 0

Advertisements


#2
Artellos

Artellos

    Tech Secretary

  • Global Moderator
  • 3,888 posts
Hello user659,

I would suggest starting to use a third party firewall software like ZoneAlarm (in my signature) because windows firewall only gives a 1 way protection if I remember correctly.
Try disableing the windows firewall and opening the ports in ZoneAlarm. (this might need extra configuration as it might not accept your local connection at first)

That should do the trick as Windows Firewall isn't something I would count on.

If you need any help setting this up let me know and I'll do anything I can to help you through.

Regards,
Olrik
  • 0

#3
user659

user659

    New Member

  • Topic Starter
  • Member
  • Pip
  • 3 posts
Thanks Olrik. I'll keep that in mind. But I really would like to find a solution that doesn't require third-party software.
The reason is that I'm working with a club of computer users and am trying to find ways we can assist each other via RDC.
We would prefer approaches that can stick with "vanilla" Windows systems.

User659
  • 0

#4
Artellos

Artellos

    Tech Secretary

  • Global Moderator
  • 3,888 posts
I myself can't assist you any further then this then.
The Windows Firewall is really bad as it doesn't really give any protection and I've only had trouble with it.
Firewall, Anti-Virus and Anti-Malware are programs that are a must on Windows or you'll end up getting a messed up windows.

Feel free to PM me if you need help with configuring ZoneAlarm.

Regards,
Olrik
  • 0

#5
user659

user659

    New Member

  • Topic Starter
  • Member
  • Pip
  • 3 posts
Well, I got it solved.

Since many others seem to be having problems in this area if there is a mixture of Vista and XP pc's,
please note that it was necessary for me to install Service Pack 3 on the XP pc's. In the SP3 writeup it does
say that version 6 of RDC is part of SP3, replacing version 5. I found that XP to XP connects did not require Version 6
nor did Vista to XP, but connections from XP to Vista required it.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP