Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Gateway driver restore problem


  • Please log in to reply

#1
texas666

texas666

    Member

  • Member
  • PipPip
  • 12 posts
A friend's Gateway 710XL has lost the drive letters for both his dvd/rw and cd/rw drives and the device manager has exclamation marks indicating driver problems. When attempting to reinstall the drivers from the Gateway utilities program, we get a message saying "HPA/SCCD/SRCD new code has encountered a problem and needs to close" and aborts driver installation.
Also used a Dell laptop to copy the contents of the Gateway 'red cd' driver cd to a thumb drive and then tried running the 'runmenu.exe' from the thumb drive with same results.
These are pata drives and the hard drives are sata and the bios looks ok but I did change the cable from secondary to primary just in case with same results...
Any ideas?

Edited by texas666, 15 May 2008 - 08:57 PM.

  • 0

Advertisements


#2
cmpm

cmpm

    Member

  • Member
  • PipPipPip
  • 561 posts
Hi texas,

Uninstall the devices from device manager then restart your computer.
They should be detected and installed with the correct drivers,
when starting the computer.
  • 0

#3
texas666

texas666

    Member

  • Topic Starter
  • Member
  • PipPip
  • 12 posts
I did that yesterday first thing and the message came up about new hardware being found and installing drivers and appeared to have worked because no messages popped up but no drive letters appear and device manager has exclamations on dvd/rw and cd/rw. When I changed the cable from secondary to primary pata port, it popped up saying new hardware found and installing drivers with same results. No error message pops up, there are just no cd/dvd drive letters and exclamation marks in device manager. Assuming the existing drivers are corrupted, I tried Gateway's driver restore utility as stated in the original post but it errors out with that "HDA/SCCD/SRCD......." message.
  • 0

#4
cmpm

cmpm

    Member

  • Member
  • PipPipPip
  • 561 posts
check this thread out
I've done this on a computer when both optical drives did not appear correctly
if it doesn't work then the instructions for restoring would be to merge the .reg file back into your registry

http://www.geekstogo...92#entry1233792
  • 0

#5
texas666

texas666

    Member

  • Topic Starter
  • Member
  • PipPip
  • 12 posts
Thank you cmpm - I believe that will fix it. I have to wait until he feels well enough to call me(he's getting chemo) so I can talk him through the steps. I will update post with the results.
  • 0

#6
cmpm

cmpm

    Member

  • Member
  • PipPipPip
  • 561 posts
Cool,
though I'm sorry about your friend feeling bad.
I do hope he gets better.
  • 0

#7
texas666

texas666

    Member

  • Topic Starter
  • Member
  • PipPip
  • 12 posts
Thank You cmpm
Hurray! He called - we ran through steps outlined and Viola! dvd and cd devices reappeared.
He asked how this could have happened and I explained that in the world of PCs that question is always answered with a shrug of the shoulders and a far off look in the eyes. At least, that's how I do it.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP