Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

help for Vista based laptop


  • Please log in to reply

#1
blueskieswoman

blueskieswoman

    Member

  • Member
  • PipPip
  • 58 posts
Hello! I am thrilled to say that I have been given a brand new HP laptop w/Vista Home Premium! And you would think all would be hunky-dory. It's not & I don't know what's wrong or how I fix it, if indeed there is anything to fix.

It has Webroot Spyware & Antivirus software installed, I tried to install the free firewall but cannot get that to work. It looks like Windows firewall is going tho. Is it good? All updates for Vista, Webroot, etc. are automatic. One of the updates for HP from Microsoft will not install -- always fails & no one can seem to give me an answer why. I installed the ATF cleaner from your site too. Should I install spybot search & destroy also? What else should I do to be proactive against spyware/viruses/malware, etc.?

I installed Billeo because it is supposed to give me added security & it really helps me with passwords & logging on to sites. Does it? It sure is handy, but I am having problems. Is this a safe program?

I use Firefox & when working on the internet, all of a sudden I get a message that Windows is having a problem & it needs to close, also Yahoo does the same thing. It all closes but when I restart Firefox, it restores my session. This worries me. Also, it seems to be slowing down after 3 weeks. Have I done something wrong? All downloads from email are checked & I only download it if it says there is no virus. Is that the correct thing to do?

Granted, these are not major things but one of the sweeps by Spysweeper found a virus that was rated a level 4, so I quarantined it & then deleted it. I do the same with the tracking cookies. Again, am I doing the right thing?

With this new computer, I am trying to make certain that I do the right thing from the start & don't mess it up.

After all the help y'all have given me, I feel silly asking about this but y'all are the experts I rely on. So, if anyone has time to help me (pls remember you are dealing with a chemo-brain, radiated, experimental-cancer drug-tested blonde :) ) and be very specific on instructions so I can print them out & follow them.

I understand these are not major probs or an emergency & y'all may not have time to deal with it. If not, pls. let me know & I'll just live with what I have.

Thank you, in advance, for reading thru all this!!!
  • 0

Advertisements







Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP