Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

Sony RW DW-Q120A won't recognize DL+ or R+ media

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 2 posts
I've been burning DVD's with this unit for over a year with no problems. I decided to burn off a series for my sister and wanted the larger capacity of the +DL. I've been burning with Memorex and Verbatim media with good results, so I got Verbatim DVD+R DL . I use Nero 7 Ultra as well as Convertx to DVD for my normal burning needs. I converted the series and inserted a DL disc to burn...got the message to insert writable media to begin burn. I tried several different discs thinking perhaps I had a hockey puck, all with the same results. I then tried to use my normal discs that have been working fine and got the same message. I figured a firmware update would fix the problem, I had PSY1 and flashed up to PSY3. Tried to burn with both +DL and +R once again and still get the message. The unit will read previously burned discs. I've tried uninstalling and reinstalling the burner with no improvement.

This problem is with my Sony RW DW-Q120A burner. I'm at a loss now and wonder if anyone can suggest further fixes. I hate to replace the unit if this problem can be fixed.

Thanks in advance!
  • 0




    Global Moderator

  • Global Moderator
  • 6,585 posts
I don 't have any clear cut solutions for you. I know this problems can be very frustrating. I spent some time today looking through the cdfreaks forums to see what they suggested. Your using verbatim media and you have flashed the drive. I also know that your drive is not made by sony, but is a rebadged Lite-on drive. I have low opinions regarding lite-on drives.
  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP