Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Remove 1 hdd


  • Please log in to reply

#1
deleted

deleted

    Member

  • Member
  • PipPip
  • 48 posts
I have 2 hdd on my pc,one with 98SE,C drive,and one with XP SP2,D drive.The 98SE was for the grandchildren to play the older games which they no longer play.So,with their permission,I decided to remove the hdd with 98SE on it,since it was no longer being used and it took so longer to do tests on the pc,such as virus scans and other such tests.Now,to the problem.I disconnected the ribbon and power cables from the hdd and now when booting I get this:HTDLR is missing,ctrl+alt+del to restart.This procedure takes me right back to the the same thing on restart.The ribbon end parted on removal and I used a spare I had but I' not able to hook up both hdd without getting another ribbon.The system sees the hdd but I'm not able to boot.
I know there's reference to this problem,but I feel this is a result of removing one of the hdd.It's possible,I guess,it has somthing to do with the removed hdd is the C drive,but,I don't know how to change that.I have lost my,payed for by me,XP cd,so I'm not able to use that to do any repairs.
Dave
  • 0

Advertisements


#2
The Skeptic

The Skeptic

    Trusted Tech

  • Technician
  • 4,075 posts
1: If the OS is not required on the disk with the 98, why not backup the data from this disk, format it and use it as extra storage space.

2: If you wish to disconnect the win98 disk anyway, then the remaining disk should be jumpered correctly. It should be jumpered as Master, or Single, or Cable Select, depending on the manufacturer's requirements. It should be connected to the end connector on the flat cable. Don't force the cable in. If you need, look on the pins on the HD to make sure that none is bent. If there are any bent pins straighten them carefully with a screwdriver or another tool.

3: Please note: there are two types of flat cables: a 40-lead 40-pins connector and a 80-lead 40-pin connector. Most hard disks need the second type. You can use the first type but data transfer speed will be limited.
  • 0

#3
deleted

deleted

    Member

  • Topic Starter
  • Member
  • PipPip
  • 48 posts
Thanks Skeptic,
I'm checking everything again.I didn't remove the hdd,just disconnected it.I'll need to get another cable to hook up both,but that's a good idea to use it as a backup,but I guess I would need a program to manage both of them.XP made it possible to choose whish one to use but I had to reboot to switch.I'll let you know if I get this thing going again.
Thanks again,
Dave
  • 0

#4
wannabe1

wannabe1

    Tech Staff

  • Technician
  • 16,645 posts
Hello deleted...

it has somthing to do with the removed hdd is the C drive

As your boot instructions are located on the C: drive by default, you'll need to get that drive connected before the machine will boot.

The prompt for which operating system to start can be addressed by editing the boot.ini file and the unwanted Windows directory can be removed once the machine is running again.

wannabe1
  • 0

#5
deleted

deleted

    Member

  • Topic Starter
  • Member
  • PipPip
  • 48 posts
I checked everything and it's as it should be,connected to the end of the cable,jumper set as master,blue plug on mob.Still have problem.
Wannabe1,
I'm don't know how to edit the boot.ini file,but I do remember that somewhere it was set to boot on XP,but I don't remember how I did that.I'll go get another cable and put both hdd back in and start over again.
thanks to both of you,
DAve

Edited by deleted, 11 June 2008 - 07:46 AM.

  • 0

#6
deleted

deleted

    Member

  • Topic Starter
  • Member
  • PipPip
  • 48 posts
I've got everything back as it was temporarily and the pc is working again.If you can give some instructions as to how to edit the boot.ini file I would like do that.
Thanks,
Dave
  • 0

#7
wannabe1

wannabe1

    Tech Staff

  • Technician
  • 16,645 posts
In Windows XP...

Right click on My Computer and choose "Properties". Click on the "Advanced" tab, then, in the Startup and Recovery section, click on the "Settings" button.

In the window that opens, click on the "Edit" button...a notepad window will open (boot.ini). Copy the contents of that window and paste it here for me.
  • 0

#8
deleted

deleted

    Member

  • Topic Starter
  • Member
  • PipPip
  • 48 posts
hope this works;
[boot loader]
timeout=15
default=multi(0)disk(0)rdisk(1)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Microsoft Windows XP Home Edition" /noexecute=optin /fastdetect
C:\="Microsoft Windows"
  • 0

#9
wannabe1

wannabe1

    Tech Staff

  • Technician
  • 16,645 posts
Remove the text shown in red below. Then click "File" on the toolbar and choose "Save". Close the windows you've opened to do this edit.

[boot loader]
timeout=15
default=multi(0)disk(0)rdisk(1)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Microsoft Windows XP Home Edition" /noexecute=optin /fastdetect
C:\="Microsoft Windows"

This will have the machine automatically boot to the installation on the D: drive without the prompt. While the machine will boot and run ok in this configuration, it's not the recommended configuration for a single installation of Windows.

---------------------<>-------------------

Do you have your XP installation CD in case we need to make some adjustments using Recovery Console?

If you want to have the correct configuration, we'll see if we can trick XP into starting properly when you swap the drives around. Copy the modified boot information below and paste it into a new notepad window. Name this file boot.ini and save it to the root of the D: drive. (D:\)

[boot loader]
timeout=15
default=multi(0)disk(0)rdisk(1)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home Edition" /noexecute=optin /fastdetect

Then you'll need to remove the C: drive (current Primary Master) and change the jumpers to the Slave position. You'll also have to change the jumpers on the D: drive (current Slave) to the Master position.

Connect the end connector of the IDE cable to the new Master drive and the center connector to the new Slave drive.

See if the machine will boot in the new configuration. If it won't boot, change the drives and jumpers back to the way they were and it should boot up.

Let me know how it goes...
  • 0

#10
deleted

deleted

    Member

  • Topic Starter
  • Member
  • PipPip
  • 48 posts
I don't have xp installation cd,been look for it for over a year.I will try to get it to boot the correct way.Do I need to do the first part before I do yhe second part?what is the correct configuration you speak of?
  • 0

Advertisements


#11
deleted

deleted

    Member

  • Topic Starter
  • Member
  • PipPip
  • 48 posts
This may be over my head,I probably should take it to a pro or leave it as it is.Or I could buy another installation cd,no use looking any longer,and start over from scratch.I'm not sure haow to erase the part you say erase,or how to paste into anew notepad.I really don't know muck about using all the stuff on here.I need to learn.
  • 0

#12
deleted

deleted

    Member

  • Topic Starter
  • Member
  • PipPip
  • 48 posts
I tried it,didn't work,no harm done.I'm back on the air and it's booting to D without a prompt.
I may not have done what needed to be done because I didn't understand the part about(save it toto the root of D: drive(D;\).
Dave

Edited by deleted, 11 June 2008 - 12:30 PM.

  • 0

#13
wannabe1

wannabe1

    Tech Staff

  • Technician
  • 16,645 posts
Just do the first part for now. Highlight the text I showed in red and press Delete....or click by the last character in the text and press the backspace key until the text is gone. Then save the change.

The correct configuration is for the system drive (the one with Windows on it) should be the C: drive. As it stands right now, you have Windows XP installed on the D: drive and Windows 98 is on C:. It should run ok for you unless you decide to format the C: drive...at which point you will loose the boot information again.

Another option is to just Delete the Windows folder from the C: drive (to reclaim the space) and let it go at that for now.
  • 0

#14
wannabe1

wannabe1

    Tech Staff

  • Technician
  • 16,645 posts
Sorry about that....I was replying when you posted... :)

The root of D: is just that. Save the file to D:/ only........not in a folder, just on the drive.
  • 0

#15
deleted

deleted

    Member

  • Topic Starter
  • Member
  • PipPip
  • 48 posts
Sorry I was so long replying,had to take the kids out on the lake and let them swim.I was just guessing and I saved it to D drive.Well we tried.I wonder what would be the result if I replaced the part I erased with C:\="Microsoft windows XP".I am going to purchase another installation cd anyway so why not try it.I'm not sure I'll be able to change it back if it does not work.Will have to look and see if I need to back up anything beforeI I try this.I'll wait to see your thoughts on this before I do anything.
Thanks,
Dave
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP