Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Can't boot from CD-ROM, BIOS seems to be set correctly though... a


  • Please log in to reply

#1
caljohn

caljohn

    Member

  • Member
  • PipPip
  • 13 posts
One of our computers has an old Abit BH6 motherboard that I believe is v1.0 and not v1.1. In BIOS, if we set the boot order for CD-ROM first, we can't get any bootable CD-ROMs to boot--instead the C drive gets booted. And strangely enough, the CD-ROM light even comes on at startup (we can hear the disk start spinning too), yet it does not get booted; BIOS always then boots the C drive. We of course verified that the bootable CDs are indeed bootable on another computer. And another strange clue is that we can change the order so that the floppy drive A gets booted first, and it works fine to boot from a floppy. :)

We even successfully updated to what I believe is the final version of the BH6 BIOS, version SS. Still we can't boot from the CD-ROM. We know the CD-ROM reads disks fine, because after booting into Windows (C drive), we can access the CD-ROM with no problems.

Does anyone have any ideas? We really could use some help! Thanks for any assistance.
  • 0

Advertisements


#2
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,019 posts
  • MVP
during bootup is there a message about a boot menu or anything like that? some bios revisions have a one time boot option (often f12) during bootup where you can force a different boot device manually
  • 0

#3
caljohn

caljohn

    Member

  • Topic Starter
  • Member
  • PipPip
  • 13 posts

during bootup is there a message about a boot menu or anything like that? some bios revisions have a one time boot option (often f12) during bootup where you can force a different boot device manually

Unfortunately, the only option on bootup is to hit the "delete" key to enter BIOS; it doesn't say anything about a boot menu or anything else. I guess I'm not surprised considering how ancient the motherboard is. Thanks for the tip, any other ideas maybe?
  • 0

#4
Neil Jones

Neil Jones

    Member 5k

  • Member
  • PipPipPipPipPipPipPipPip
  • 8,476 posts
Try a new CD unit. You'll be surprised the number of CD units that work in Windows quite happily but have developed some obscure fault that renders them unable to allow the system to boot off a CD.
  • 0

#5
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,019 posts
  • MVP
ack...forgot to come back hehe

another thing to try is to disable any option in the bios that mentions quick boot or something to that effect
  • 0

#6
caljohn

caljohn

    Member

  • Topic Starter
  • Member
  • PipPip
  • 13 posts

Try a new CD unit. You'll be surprised the number of CD units that work in Windows quite happily but have developed some obscure fault that renders them unable to allow the system to boot off a CD.

Unfortunately I don't have that option as I don't have any other available CD-ROMs to substitute.

I pulled open the computer case again and I got some useful information: the CD-ROM is a Toshiba XM-6302B that is connected to my IDE2 connector (HD is connected to IDE1), and it is jumpered (I assume correctly) for master. I also noticed that on boot-up (without entering BIOS), there is a screen that shows the detected IDE drives, and it does show my HD and Toshiba CD-ROM. I went into BIOS and instead of setting the boot order to start with CD-ROM, I tried setting E drive as first since my HD is C, the slave would be D, so my CD-ROM drive in IDE2 should be E, correct? Didn't work though. :)

And BTW dsenette, there is no "quick boot" option that I can find. Any more ideas? I'm beginning to lose hope on getting that particular CD-ROM to work on boot-up at this point. :)
  • 0

#7
vally

vally

    Member

  • Member
  • PipPipPip
  • 573 posts
Try to borrow a cd rom from a friend. Not a dvd player. On these old mother boards they wont always boot from a dvd.

Have you tried different boot able disks? There are some disks that wont boot from all computers.
  • 0

#8
Tyger

Tyger

    Member 2k

  • Member
  • PipPipPipPipPip
  • 2,896 posts
All those suggestions are good but in this circumstance this is what I do. You can put something called SmartBootManager on a floppy and when you boot it, it will then allow you to boot from any device. It can be a little tricky, sometimes you have to try a couple of times, but it almost always gets the job done. Just Google for:

smartbootmanager +download
  • 0

#9
caljohn

caljohn

    Member

  • Topic Starter
  • Member
  • PipPip
  • 13 posts

All those suggestions are good but in this circumstance this is what I do. You can put something called SmartBootManager on a floppy and when you boot it, it will then allow you to boot from any device. It can be a little tricky, sometimes you have to try a couple of times, but it almost always gets the job done. Just Google for:

smartbootmanager +download

A huge thank you and kudos to you, tyger--the "SmartBootManager" turned out to be a perfect solution. Absolutely no problems booting from CD-ROM now. :) I'm so glad I don't have to mess with the BIOS on that old motherboard any more!

In case someone else stumbles on this thread in the future, I'll save you some time by giving you the exact steps I used to boot from my CD-ROM with Smartbootmanager:

1. Download SmartBootManager 3.7.1 from: http://btmgr.sourcef...3.7/sbminst.exe
2. Open a terminal window (Start > Run... > cmd), navigate to the folder where you saved "sbminst.exe" in, insert a blank floppy in your A drive, and type "sbminst -t us -d 0", hit return, and voila! you now have a floppy with the SmartBootManager installed on it. ("-t us" option installs the smartbootmanager in english, and "-d 0" installs it onto the first drive, or the floppy A drive).
3. Make sure your BIOS is set to boot from a floppy; when booting from the floppy you created it will give you the option to boot from the CD-ROM (if it is detected).
4. If you can't even boot from a floppy, it is possible to install SmartBootManager on your C drive with: "sbminst -t us -d 128 -b backup_mbr" where the "-b backup_mbr" option will make a backup of your current MBR (saved as "backup_mbr") before overwriting your master boot record (MBR) with SmartBootManager.

Also, many thanks to everyone else who offered their ideas for troubleshooting my problem. :)
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP