Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

WOW Black Screen of Death or is it Pink


  • Please log in to reply

#1
nethkhar

nethkhar

    Member

  • Member
  • PipPip
  • 45 posts
Hi,

I have had this problem for a while now. I play WOW far too much really, and occasionally the screen will just blank out.

Sometimes it's black sometimes it's pink sometimes it's brown. What's weird is the game is still playing. I can hear the sound I can still chat with my mates. So the sound is ok and the game is still actually running. However there is just no display. The only way to get it back is by a hard restart.

I have a XFX nvidia Geforce 8800GT graphics card, 2G of ram, Intel core 2 duo 2.66, a corsair 620w PSU and a gigabyte S series motherboard model No GA 73pvm S2H.

The monitor is a Viewsonic vx2240w.

Can anyone suggest what the problem might be as I thought this system would be more than capable of dealing with intense graphics requirements.

OS is XP. The Graphics card temp is constantly 40% mainly because it's impossible to turn the fan off. Looking through event viewer no errors seem to be detected, and one more thing, this only happens while playing WOW.

Any suggestions on what it might be??

Thanks in advance.
  • 0

Advertisements


#2
Artellos

Artellos

    Tech Secretary

  • Global Moderator
  • 3,888 posts
What happens if you play WoW on a lower settings graphics wise?
It might be your drivers that don't function properly.
You can try to re-install your video drivers, see if that helps.

Regards,
Olrik
  • 0

#3
nethkhar

nethkhar

    Member

  • Topic Starter
  • Member
  • PipPip
  • 45 posts
Thanks for the reply, I have reduced the settings marginally, and i have played the game and upto now everything is fine.

I won't know for certain for a few days since it only happens maybe once every couple of days.

I have also downloaded and installed the latest drivers.

If this works it may help quite a few people because this appears to be a common problem with WOW.

Thanks again.

Edited by nethkhar, 26 June 2008 - 06:36 AM.

  • 0

#4
Artellos

Artellos

    Tech Secretary

  • Global Moderator
  • 3,888 posts
If you can, post back in a couple of days with the results thus far :)
It would help us and a lot of other people!

Regards,
Olrik
  • 0

#5
nethkhar

nethkhar

    Member

  • Topic Starter
  • Member
  • PipPip
  • 45 posts
Hello,

It has been a few days now and the problem hasn't returned. So everything looks ok now. Just for clarification the only video change i made in WOW was switching off character shadows. I also installed the latest device drivers for the card.

I am going to reset the character shadows after a week to see if the problem returns If only so i can see if it was the drivers or the setting.

Thanks for the help, I hope i haven't jinxed myself now by saying everything is ok. :)

Nethie
  • 0

#6
Artellos

Artellos

    Tech Secretary

  • Global Moderator
  • 3,888 posts
Glad we could be of assistance!! :)

Regards,
Olrik
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP