Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Wamp server virtual hosting problems


  • Please log in to reply

#1
sasuke781

sasuke781

    Banned

  • Banned
  • PipPip
  • 54 posts
im trying to host 2 sites with the same ip using 2 different dns names. www.eblog.dnsdojo.com and www.multiforums.dnsdojo.com. When i have my dir set as the folders are, for example my folder for eblog is C:/wamp/www/eblog it adds another /eblog to the end (What the...) and when its set as just www it shows my wamp index to everyone. here is my httpd.conf http://pastebin.com/m65b8d7a3

if you need anything else just ask and ill post asap

thanks in advance

This is on Windows XP SP2 right now

Edited by sasuke781, 20 July 2008 - 02:09 PM.

  • 0

Advertisements


#2
sasuke781

sasuke781

    Banned

  • Topic Starter
  • Banned
  • PipPip
  • 54 posts
Bump....i kinda need this fixed
  • 0

#3
sasuke781

sasuke781

    Banned

  • Topic Starter
  • Banned
  • PipPip
  • 54 posts
bump...
  • 0

#4
wizzy2k5

wizzy2k5

    Member 1K

  • Member
  • PipPipPipPip
  • 1,057 posts
sasuke781

Bumping your thread will mean you waiting longer to get a reply as our helpers will look for threads with 0 replies first, also bumping your thread is considered rude and bad forum etiquette. Please wait and someone will be with you.

I am unable to help here as I do not know alot about web development/servers etc... however if you do not get a reply within 3 days of posting your orignal topic please feel free to post it in the waiting room which is here

Regards
  • 0

#5
Titan8990

Titan8990

    Member

  • Member
  • PipPipPipPipPip
  • 2,189 posts
So the only issue you are having is getting the correct document root for eblog?
  • 0

#6
sasuke781

sasuke781

    Banned

  • Topic Starter
  • Banned
  • PipPip
  • 54 posts
-_- read again please....the server doesnt send anything to anyone that visits....it tells anyone that trys to go to it "server not found"
  • 0

#7
Titan8990

Titan8990

    Member

  • Member
  • PipPipPipPipPip
  • 2,189 posts
Does your ISP block port 80?

From your OS list: "soon server loaded with Debian with wine"

Do you know that a Debian server edition does not have a GUI?

Edited by Titan8990, 04 August 2008 - 11:00 AM.

  • 0

#8
sasuke781

sasuke781

    Banned

  • Topic Starter
  • Banned
  • PipPip
  • 54 posts
no my isp does not block port 80, and my OS list is out of date because debian would never work right for me. I used ubuntu server instead and installed a gui on it long enough to learn it. and im still doing this on a windows machine.
  • 0

#9
Titan8990

Titan8990

    Member

  • Member
  • PipPipPipPipPip
  • 2,189 posts
So you are still having two issues?

One: Have not created an index.html page or set a default page for the root of your webpage.

Two: People from outside the network can not access your web page.


Is this correct?

#
NameVirtualHost *:80
#

#
<VirtualHost *:80>
#
ServerName www.eblog.dnsdojo.com
#
ServerAlias eblog.dnsdojo.com
#
DocumentRoot "C:/wamp/www/eblog"
#
ErrorLog c:/wamp/logs/eblog_error.log
#
</VirtualHost>
#

#
<VirtualHost *:80>
#
ServerName www.multiforums.dnsdojo.com
#
ServerAlias multiforums.dnsdojo.com
#
DocumentRoot "C:/wamp/www/multiforums"
#
ErrorLog c:/wamp/logs/multi_error.log
#
</VirtualHost>


Should look more like this:

#
NameVirtualHost *:80
#
 
#
<VirtualHost www.eblog.dnsdojo.com:80>
#
   ServerName www.eblog.dnsdojo.com
#
   ServerAlias eblog.dnsdojo.com
#
   DocumentRoot "C:/wamp/www/eblog"
#
   ErrorLog c:/wamp/logs/eblog_error.log
#
</VirtualHost>
#
 
#
<VirtualHost www.multiforums.dnsdojo.com:80>
#
   ServerName www.multiforums.dnsdojo.com
#
   ServerAlias multiforums.dnsdojo.com
#
   DocumentRoot "C:/wamp/www/multiforums"
#
   ErrorLog c:/wamp/logs/multi_error.log
#
</VirtualHost>

Edit: Why not do this on your Ubuntu box where Apache is optimized (Linux)? Have you edited your hostfile so that your local machine knows that it handles these domains?

Edited by Titan8990, 04 August 2008 - 05:17 PM.

  • 0

#10
sasuke781

sasuke781

    Banned

  • Topic Starter
  • Banned
  • PipPip
  • 54 posts
actually i posted my httpd.conf, its the pastebin link that you see on the first post.....and i intend to do this on ubuntu once i get all of my other things on ubuntu worked out, which is why for now im trying to figuire out what i did wrong on windows since its all setup, then ill just port it to ubuntu....and i was unaware i needed to edit the hostfile on windows, can you tell me how that needs to look.....maybe something like this

127.0.0.1 www.eblog.dnsdojo.com
127.0.0.1 www.multiforums.dnsdojo.com

???
  • 0

Advertisements


#11
Titan8990

Titan8990

    Member

  • Member
  • PipPipPipPipPip
  • 2,189 posts
The Ubuntu version of Apache is different from all other versions. The major difference being it does not use a httpd.conf file. Instead it breaks this file down in to multiple parts and uses symbolic links to reference them. You will want to reference the hostname of the server in which web traffic is coming from.

I don't have much experience with Windows host files but in linux the correct syntax would be:

127.0.0.1 www.eblog.dnsdojo.com www.multiforums.dnsdojo.com

not

127.0.0.1 www.eblog.dnsdojo.com
127.0.0.1 www.multiforums.dnsdojo.com

You want it to point to your local IP because thats where traffic for your domain is going to be coming in at. So if your local ip is 192.168.1.10:

127.0.0.1 localhost
127.0.1.1 MYCOMPUTERSHOSTNAME
192.168.1.10 www.eblog.dnsdojo.com www.multiforums.dnsdojo.com
192.168.1.1 MYSERVER

Here is an example of my from my work's Ubuntu server that runs two websites and one email server on three seperate domains:

jordan@einstein:~/python$ cat /etc/hosts
127.0.0.1 localhost
127.0.1.1 einstein.SSDLLC.local einstein
192.168.16.24 mail.MYDOMAIN.com projectmanagement.MYOTHERDOMAIN.com mail.MYTHIRDDOMAIN.com
192.168.16.1 SSDFLA.SSDLLC.local

Edit: I did an nslookup on your domain and you should know that I am not even able to ping it. Check your router/firewall setting to ensure that you are allowing traffic in and out (but not to the point where the security of the server can become compromised).

Edit 2: It also looks like you are using Bellsouth ISP. You should note that their home service does in fact block port 80 and is against their AUP to host a web server.

Edited by Titan8990, 06 August 2008 - 10:39 AM.

  • 0

#12
sasuke781

sasuke781

    Banned

  • Topic Starter
  • Banned
  • PipPip
  • 54 posts
well you told me what should be there but not what file that needs to be edited lol. As for bellsouth/at&t blocking port 80, i dont see how thats possible since 80 is for web traffic so if they did block it i shouldnt be able to get on here, as well as that being said i called them just now as i did 3 months ago when i started this and they both told me that a web server can be run on this isp. Btw, i wasnt running wamp nor the dyndns updater when you tried to ping....so please try again now that i have it running
  • 0

#13
Titan8990

Titan8990

    Member

  • Member
  • PipPipPipPipPip
  • 2,189 posts
It wouldn't matter if you were running a your web services or not. Something like a firewall is filtering ICMP (ping) packets.

It is very common for ISPs to block port 80. They are able to filter these ports because it is uploading on port 80 as opposed to downloading on port 80.

Do you have the ports foreworded correctly on your router?
  • 0

#14
sasuke781

sasuke781

    Banned

  • Topic Starter
  • Banned
  • PipPip
  • 54 posts
well of course i have a firewall running lol i only gave httpd.exe full access. i guess i need to do more =P. and i think i have them forwarded properly, port 80 on the hosting computers ip.
  • 0

#15
Titan8990

Titan8990

    Member

  • Member
  • PipPipPipPipPip
  • 2,189 posts
DId you set up your devices to have a static IP so your router wouldn't start forwarding to the wrong machine?
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP