Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

email hyperlinks do not work in Firefox browser


  • Please log in to reply

#1
tophat2u

tophat2u

    New Member

  • Member
  • Pip
  • 2 posts
I have windows xp
Firefox is my browser...
[don't lecture me for this--I like it] Incredimail is my email.


In my browser, I cannot open email links. Nothing happens. It used to work and I tried system restore to a month earlier...it didn't work.

In reading around the web I found posts that said to go to
control panel
folders option
file option
look for the 'mail to' protocol
highlight it and hit advanced and
UNCHECK the DDE box.

I have several times and the box will not STAY unchecked.

Any help you can give me would be much appreciated...
Thanks
  • 0

Advertisements


#2
TechSabre

TechSabre

    Member

  • Member
  • PipPip
  • 74 posts
Hello and welcome to Geeks to Go :)

After checking the box, did you press Apply/Ok?
  • 0

#3
tophat2u

tophat2u

    New Member

  • Topic Starter
  • Member
  • Pip
  • 2 posts
Yup, I clicked on OK...then went back and looked and DDE was checked again. Did the entire thing many times over, always clicking okay, DDe always came back. Ug...
[/i]



Hello and welcome to Geeks to Go :)

After checking the box, did you press Apply/Ok?


  • 0

#4
Major Payne

Major Payne

    Retired Staff

  • Retired Staff
  • 5,307 posts
Any chance you need to go to "Set Program Access and Defaults" to make sure those are set? It might be related to Windows' Updates/IE7 as reported by some people:

hyperlink and mozilla firefox
Links Outlook Express Email open to file explorer
Hyperlinks To Firefox & IE7 Not Working From Email & Web Pages Vista Bus
Hyperlinks not working in received email (firefox)

Not the posting dates for these and you'll see this seems to be an off/on problem over a period of time. What the exact solution is I don't know, but you might try some of the steps listed in following links even though they are related to IE.

Links in email do not work
Hyperlinks Don't Work
In OE, IE won't respond to a Hyperlink

I think it is realted to Windows and Internet Options as IE is so tighly integrated with Windows and may affect settings for other default programs used.

Ron
  • 0

#5
starjax

starjax

    Global Moderator

  • Global Moderator
  • 6,591 posts
I had a similar issue. This is what I did to resolve it:
must be applied after every firefox update
For Windows Vista

When using the following: Windows Vista with Office 2007 and Firefox. When click on a link in the sidebar or in Outlook you may get the following:

General failure the url was: access denied
or
General failure the url was: "system can not find the file specified"

Either way, the path to fixing it is the same. Open up regedit and go to the following registry key:

HKEY_CLASSES_ROOT\FirefoxURL\shell\open\ddeexec

Double click on the Default string, which should have a value of ""%1",,0,0,,,,". Delete that value and leave it blank.


Restart the pc and life should be good.

For Windows 2000/ XP with outlook 2007 and Firefox:

File Types edit

(In Windows XP and Windows 2000)

1. Open Windows Explorer (or My Computer).
2. Go to Tools -> Folder Options -> File Types
3. Select Extension: "(NONE)" File Type: "URL:HyperText Transfer Protocol"
4. Click "Advanced". In the "Edit File Type" window, select "open" and click "Edit"
5. Uncheck "Use DDE" (the dialog should then hide the lower part)
6. Click OK for that dialog and the next one (afterwards the DDE message box will be cleared, as shown here)
7. Repeat for Extension: "(NONE)" File Type: "URL:HyperText Transfer Protocol with Privacy" (and any other protocols you want to fix)
8. Repeat for Extension: "(NONE)" File Type: "Firefox URL"
9. Repeat for Extension: "HTM" (or "HTML") File Type: "Firefox Document"
  • 1

#6
Sking0

Sking0

    Member

  • Member
  • PipPipPip
  • 172 posts
Hi. I appreciate this topic is quite old but i cannot find anything on the web that works for me.
I have windows XP SP3. Using Mozilla Firefox 7. Outlook Express.
When i do what starjax says regarding unchecking the necessary boxes i can click on links in emails and it works ok.
However, if i turn firefox off and try to open a link in an email later on that day it does the same thing (won't open the hyperlink) and all the boxes i unchecked
are checked again? When i do the 'unchecking' in the first place and i have clicked ok it does not give me the option to 'apply'. The apply box is greyed out.
Firefox is set as browser. I use Zonealarm, 'No-Script' add-on, and spyware blaster (if that is relavant!?)
Also bookmarks take me to a blank page if i have Outlook express open, if i close it the bookmarks still don't work. I have to close outlook express and restart firefox for bookmarks to work.
Any suggestions will be appreciated. If you need anymore info let me know.

Edited by Sking0, 05 November 2011 - 07:00 AM.

  • 0

#7
Sking0

Sking0

    Member

  • Member
  • PipPipPip
  • 172 posts
Nevermind. I figured it out myself.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP