Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Having problems with this headset


  • Please log in to reply

#1
Efeezy25

Efeezy25

    New Member

  • Member
  • Pip
  • 6 posts
Hey guys, I am having this issue where I bought a Cyber Acoustics HS-600 Headset for my laptop to talk on Ventrilo and Teamspeak. Well every time I plug in the inputs for the headset, which has a microphone and headset input plugs, and try to talk on Ventrilo or Teamspeak there is nothing but like a gust of wind every time. I have tried to mess with the microphone boost in the volume advance settings no dice. The only time I am clearly able to talk and my friends hear me is which I put the actual microphone basically inside of my mouth, sounds weird yes I know but had to make sure it wasn't completely busted. So if you guys can possibly tell me a solution would be greatful thanks
  • 0

Advertisements


#2
Titan8990

Titan8990

    Member

  • Member
  • PipPipPipPipPip
  • 2,189 posts
Could it have anything to do with Cyber Acoustics not making a model HS-600? Cyber Acoustics headsets follow a AC-xxxx naming convention.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP