Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

Very strange USB Problem

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 1 posts
I just recently got a new laptop. I have several USB devices (Palm, HP printer, wireless receiver for keyboard and mouse, scanner). They all work when plugged directly into the USB roots on the computer. However, they do not work properly when plugged into a USB hub. The hub is powered (I've tried three seperate hubs). Communications still happens, but they do not work properly (the Palm crashes, the printer prints garbage, the keyboard and mouse work intermittently).

Things I've tried:
-Tried them powered and unpowered
-Killing and Reinstalling all USB roots in device manager
-Used three different Hubs (2 USB2.0 hubs and 1 USB1.1 hub)
-Tried one device at a time
-Tried one device at a time after killing and reinstalling the roots

This is crazy and I'm at my wits end. I'm a pretty advanced user, so this is awfully frustrating. Can anyone help me?

Thank you!
  • 0





  • Member
  • PipPip
  • 43 posts
Hi there, and I feel for you....

Here is what is happening in your system.

You USB is powered with 5 VDC for the entire usb system. (yes both ports) (Most laptops have an over under style port)

If you are using the items one at a time, the system can cope, as you have described. The powered hubs are supposed to take the strain off the laptop's power supply by providing the hub's power to power your devices. For what ever reason ( and this is the part I can not explain) it is not releasing that control over. It may be a loose connection in the port, or in the driver command configuration.

I would highly recommend that you contact you laptop's manufacturer's website, to see if there are additional drivers, or if they have an FAQ that might clue in to what you might be able to do about this.

In the meantime, go to your system bios, and see if there is an option to set the parameters for the usb ports.
You may also have an IRQ problem where too many things are requireing computer resources. (doubtful, but why not look just to be sure).

I know this is not much in the way of help... but good luck anyway...

(ps, if you had included your model type, I would have looked online to make sure my information was accurate, and passed it too you or if there was anything I could have found.)
  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP