Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Audio Drivers And Windows XP 64bit


  • Please log in to reply

#1
joncommander

joncommander

    New Member

  • Member
  • Pip
  • 2 posts
OK, I was using xp 32bit and the drivers for the onboard sound where fine. got xp 64bit and they wont work. i downloaded the proper 64bit drivers from the asus website (who suplied the drivers for my motherboard) but it still dosent work. Xp seems to list the audio hardware but just dosent do anything with it. I thought there may be a problem with the Microsoft HD UAA bus drivers so i installed them for xp 64 but still no luck. How can I make the drivers work?

Thanks,

Jon
  • 0

Advertisements


#2
jaxisland

jaxisland

    Member 1K

  • Member
  • PipPipPipPip
  • 1,703 posts
Go into Device Manager
Start - Run - type: devmgmt.msc
Hit enter

Now in device manager if you see anything with yellow exclamation points right click and unistall. After they are uninstalled, reboot. Let windows find them and them allow windows to install the driver again. It should prompt after you reboot.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP