Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

Soundcard not working!

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 1 posts
Hi, I am currently using windows XP and have an audigy SE 7.1 soundcard. I got the pc from a friend
and dont have the cd for it, I did however download the driver from the internet and it has ben working fine for the past few days.
Today however, my sound has randomly stopped working and I dont think my pc now has the software for the card because
it detects it as it comes up with PCI found but it dosent work. I have checked all the plugs leading into it and they are fine.
If I go onto sounds and audio devices its all greyed out. I tried to reinstall the driver but it comes up with an error message
saying "setup is unable to detect the supported product on your system". The only thing I can think of is that I used tune up utilites 2008
to stop a few programs from starting when Turn on my pc allthough I dont think I touched anything to do with sound
Any help would be much appreciated
  • 0


Philip Kingsley

Philip Kingsley


  • Member
  • PipPip
  • 43 posts
Looks like its PCI card. Try unplugging the card and replugging it!!
  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP