Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Help Setting Up Server


  • Please log in to reply

#16
Troy

Troy

    Tech Staff

  • Topic Starter
  • Technician
  • 8,841 posts
Tried kubuntu desktop option, got this:

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package kubuntu-desktop

I'm guessing it's supposed to install it from the internet, but I need to get the wireless working first...

Troy

EDIT: The disc was in the drive too, but I don't think it looked there...

Can I run the normal edition of Ubuntu (desktop) to run the server?

Once I get that sorted out and working, I'll try the server edition. This will be once I have had a lot more practice with the Terminal (commands).

I might partition the drive into two 40GB parts and run a dual boot...

What do you think of this? Currently I'm thinking it's way over my head... :)

Edited by troy, 06 September 2008 - 09:32 AM.

  • 0

Advertisements


#17
silverbeard

silverbeard

    Trusted Tech

  • Member
  • PipPipPip
  • 791 posts
sudo apt-get install xserver-xorg
sudo apt-get install kde-core

For a graphical login
sudo apt-get install kdm

If you don't like Kpackage as a package manager (I prefer Synaptic)

Sudo apt-get install synaptic

Reboot and you should have a graphical login and a GUI to work in and none of the Kubuntu branding.

My bad for thinking Aptitude would be installed by default. It's the original graphical package manager for a terminal environment. I always try to launch it in a command line environment and if it's not there I install it. It was the bomb when I started using Debian and it's better now then it was then.
  • 0

#18
Titan8990

Titan8990

    Member

  • Member
  • PipPipPipPipPip
  • 2,189 posts
Aptitude is installed by default. It is not able to install the package because he has no network connection. I will post back later with a tutorial for installing .deb packs w/o a internet connection.
  • 0

#19
Titan8990

Titan8990

    Member

  • Member
  • PipPipPipPipPip
  • 2,189 posts
Alright, first lets get your wireless working. It looks like ndiswrapper can be installed from the cdrom if added to your source repositories.

sudo apt-cdrom add
sudo apt-get update
sudo apt-get install ndiswrapper-common ndiswrapper-utils-1.9


Give that a shot and see if it installs ndiswrapper successfully.sudo apt-cdrom add
sudo apt-get update
sudo apt-get install ndiswrapper-common ndiswrapper-utils-1.9
  • 0

#20
Troy

Troy

    Tech Staff

  • Topic Starter
  • Technician
  • 8,841 posts
Oh wow, I'm so sorry guys! :) Thanks for all your information, though...

I have formatted and installed Ubuntu desktop edition just last night!. I have removed almost all programs I don't need through both the Applications > Add/Remove, and the Synaptic Package Manager.

I have wireless working! :)

Titan, I have started working on your email tutorial located here, and have stumbled upon this error. You say input the following code:

$ swaks -a -tls -q HELO -s localhost -au jasonb -ap '[]'

And it should give me this result:
=== Trying localhost:25...
=== Connected to localhost.
[-  220 einstein ESMTP Exim 4.69 Mon, 05 May 2008 16:02:30 -0400
-] EHLO einstein
[-  250-einstein Hello localhost [127.0.0.1]
[-  250-SIZE 52428800
[-  250-PIPELINING
[-  250-STARTTLS
[-  250 HELP
-] STARTTLS
[-  220 TLS go ahead
=== TLS started w/ cipher DHE-RSA-AES256-SHA
~] EHLO einstein
[~  250-einstein Hello localhost [127.0.0.1]
[~  250-SIZE 52428800
[~  250-PIPELINING
[~  250 HELP
~] QUIT
[~  221 einstein closing connection
=== Connection closed with remote host.

Unfortunately mine does not do this, it gives the error you mention about STARTTLS and finishes. Here is the code I have on the screen right now:

=== Trying localhost:25...
=== Connected to localhost.
<-	220 mailman ESMTP Exim 4.69 Tue, 09 Sep 2008 11:24:18 +1000
 ->   EHLO mailman
<-	250-mailman Hello localhost [127.0.0.1]
<-	250-SIZE 52428800
<-	250-PIPELINING
<-	250 HELP
***  STARTTLS not supported
 ->   QUIT
<-	221 mailman closing connection
=== Connection closed with remote host.

I have manually copied all of this in (typed it in) so the formatting is off by a space... but you get the idea. I have called this computer "mailman".

Any idea what the next step would be to fix this?

Also can I edit this file ($ sudo nano /etc/courier/imapd.cnf) to be local to me in Australia, instead of changing the default (New York) to yours (Lousville)? What are the correct country, state, "L" (location?) codes for me?

Cheers,

Troy
  • 0

#21
Titan8990

Titan8990

    Member

  • Member
  • PipPipPipPipPip
  • 2,189 posts
Alright, TLS issue,,,,


First I have to ask if "MAIN_TLS_ENABLE = yes" was properly added to /etc/exim4/exim4.conf.template. This should be at the top. Here is an example of our exim4.conf.template file:

######################################################################

######################################################################
#					MAIN CONFIGURATION SETTINGS					 #
######################################################################

# Just for reference and scripts. 
# On Debian systems, the main binary is installed as exim4 to avoid
# conflicts with the exim 3 packages.
exim_path = /usr/sbin/exim4

MAIN_TLS_ENABLE = yes

# Macro defining the main configuration directory.
# We do not use absolute paths.
.ifndef CONFDIR

That is about where TLS should be defined. This config file in particular is what make exim4 tricky. Phillip Hazel wrote his own version of regular expression of exim4 and that config file.



Now, do you get an error if you remove the -tls flag? Example:

$ swaks -a -q HELO -s localhost -au troy -ap '[]'


Also can I edit this file ($ sudo nano /etc/courier/imapd.cnf) to be local to me in Australia, instead of changing the default (New York) to yours (Lousville)? What are the correct country, state, "L" (location?) codes for me?


Yes, you can but you need to keep in mind that you will need to get this certificate signed. When my company did the research we found the GoDaddy was the cheapest for cert signing at about $50 for two years. Verisign wanted somewhere around $300.

You don't have to have your certificate signed by users may be presented with a warning message if it is not.

As far as your locations, I am not sure. You could go to an Australian site that uses HTTPS and view their certificate.

I have manually copied all of this in (typed it in) so the formatting is off by a space... but you get the idea. I have called this computer "mailman".


You can append standard outputs of a command to a file:


swaks -a -tls -q HELO -s localhost -au jasonb -ap '[]' > test.txt


will put the results of the swaks command in to test.txt


Let me know how far that gets you.

Edited by Titan8990, 09 September 2008 - 11:34 AM.

  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP