Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

New Hard Drive Not Detected

  • Please log in to reply




  • Member
  • PipPipPip
  • 214 posts
Hi there... background on this issue, I thought my original hard drives were fried (they still may be), so I ordered a new one.

It got here, I smiled, installed it, downloaded the manufacturer's "non raid" raid drivers (mobile system). I set the BIOS to ATA, and proceded to the next screen of the XP Professional install. Unfortunately, it just sais drive not detected. This is what it said for my original hard drives, and now I'm getting really confused.

Step by step this is what I did, after installing hard drive (into the nearest to the mobo slot as per manual) I:
* put the battery back in
* plugged in the laptop
* powered it on, inserted disc
* went into bios, changed the boot order, and set RAID to ATA
* tried to install
* then the dreaded "drive not detected" screen shines in my face...

I realize, thanks to some advice, at this point I need a "non raid" raid driver for my laptop which I download from the manufacturer's website... then I:
* powered it on, disc is inserted
* tried to install
* hit F6 at prompt
* hit S at specify device
* install manufacturer driver
* then the dreaded "drive not detected" screen shines in my face... again :/

Is there anything else I can check or do?
  • 0





  • Topic Starter
  • Member
  • PipPipPip
  • 214 posts
I'm not sure why this was different, but I managed to get into FastBuild once. Basically I hit Esc, then Ctrl+I, Ctrl+R, F1, F3, F4, F5... Ctrl+I must have done the trick, because the FastBuild logo that is supposed to, but never does, appear appeared. I hit Ctrl+F, which it sais to do on the logo and I was in.

There were no arrays setup, but the hard drive was detected in FastBuild... a good sign I suppose.

I used auto assign and it set it up as 1 drive in RAID. When I hit save, it froze. I left it for a while, thinking it may be configuring something, but it never regained.

Hoping that it had done the trick anyway, I booted, went into BIOS, selected ATA, turned Card reader Disabled and verified the boot order... saved and exited.

After hitting F6 and installing the non raid controller, the same thing happened (drive not detected.)

I went into bios again thinking I would change ATA to RAID, just to see what would happen, and I noticed that it had automatically changed to RAID, and Card Reader was Enabled. The boot menu was also changed. I'm thinking the installation process changed this as the boot menu changed to floppy, scsi, then cd drives...

So now I'm thinking that the cable must still be in good shape, as well as possibly my old hard drives.

Would this be my BIOS or my Controller? I'm leaning toward the controller as it does not seem to load everytime? (or whatever the reason would be for the FastBuild logo to almost never appear (I've only seen it twice in all the reboots I've done since the "operating system not found" error started.))
  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP