Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Renewing IP Address and other messes!


  • Please log in to reply

#1
Atlaua

Atlaua

    New Member

  • Member
  • Pip
  • 1 posts
A friend of mine had a computer completely full of virus's and other unwanted things (malware, spyware, etc.). I proceeded to use Spydoctor and Adaware just to get rid of the major ones. It found 804 Threats and 32 Infections.

Why does this matter?

Because before we removed the unwanted things like that, his internet was working fine. He lives with a friend and they have a Linksys Wireless Router hooked to a Broadband Cable modem. There computer works completely fine wirelessly. His did too, until we removed some programs.

Afterwards though?? Mmm...

It will not work now. The problem? If I leave the TCP/IP to find it automatically, it gives me an address of 169.x.x.x which is of course an APIPA address. Anyway, when I try to connect, it will fail, and when I click repair, it will fail upon "Renewing IP Address". Now, I have searched many message boards and have tried many things they have told me to try, to no avail. If I go in and manually set the IP Address/Gateway/DNS/etc.etc.etc., it will show on the network connections that it is connected, with 5 full bars of service and with all the information. I can ping it and it responds, everything. But the packets don't really move. I will get 1 packet maybe....every minute? And of course, cannot connect to the internet. There Linksys has no password, so it is not a problem there, and remember, it worked before the unwanted crap got removed. Also, I was told to make sure the firewall is not blocking connections on the laptop. So I went to disable the firewall, just to see if it would work, but when I clicked the Firewall off, it still shows it is on. No matter what I do, even choosing OFF, it says it is still on. Help on that? Because that might be the problem.

So I guess this is my plea. HELP! If you can help me out with this, I would be more than grateful.


P.S. Things I checked are...

Making sure the Firewall is not blocking connection on the laptop.
Disable encryption on the router.
Checking and removing 3rd party firewall (security suite)
Checked to make sure all my services are started on all PC's, including 'Computer Browser, DHCP Client, DNS Client, Network Connections, Network Locations Awareness, Remove Procedure Call (RPC), Server, TCP/IP Netbios Helper, Workstation).



Help please.
  • 0

Advertisements


#2
sari

sari

    GeekU Admin

  • Administrator
  • 20,955 posts
  • MVP
Atlaua,

It's hard to say what's happening. You say:

I proceeded to use Spydoctor and Adaware just to get rid of the major ones. It found 804 Threats and 32 Infections.


If these are the only 2 products you used, chances are there's still malware present on this PC. Something could have been partially removed, and maybe some settings were changed in the process. I would suggest you go here and follow the instructions - one of our malware staff should really make sure this is clean before we try and fix the internet problem.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP