Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

IE and Firefox Certificate Error


  • Please log in to reply

#1
rsa

rsa

    Member

  • Member
  • PipPip
  • 18 posts
I am having this problem since several months ago. Everytime I go to a https site I am always having this kind of an error.

Secure Connection Failed

www.xxxxxxx.com uses an invalid security certificate.

The certificate is not trusted because it is self signed.
The certificate expired on 5/23/2008 7:59 AM.
(Error code: sec_error_expired_issuer_certificate)
* This could be a problem with the server's configuration, or it could be someone trying to impersonate the server.
* If you have connected to this server successfully in the past, the error may be temporary, and you can try again later.

Or you can add an exception…

Anyone is welcome to give suggestion/solution to this problem.
  • 0

Advertisements


#2
Amaterasu

Amaterasu

    Member

  • Member
  • PipPip
  • 45 posts
I hear that you can fix that specific error code simply by synchronizing your clock. All you have to do is right click on your clock and then select "Adjust/Date/Time". Once you're there, select the "Internet Time" tab and then choose server time, hit "Update Now" and then apply the changes.
  • 0

#3
rsa

rsa

    Member

  • Topic Starter
  • Member
  • PipPip
  • 18 posts

I hear that you can fix that specific error code simply by synchronizing your clock. All you have to do is right click on your clock and then select "Adjust/Date/Time". Once you're there, select the "Internet Time" tab and then choose server time, hit "Update Now" and then apply the changes.


I checked my time and so far its correct per checking. I've been to the "Internet Time" tab and what is placed there is "time.windows.com" the only option I have in there plus "time.nist.com". I updated it already and the problem stays the same.

Also I noticed that because of these errors I am not able to get manual updates from Wndows update.

Edited by rsa, 08 September 2008 - 12:54 AM.

  • 0

#4
lsyts

lsyts

    Member

  • Member
  • PipPip
  • 23 posts
Thank you Nor Gal. I did as you suggested and it corrected the errors I was getting.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP