Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

USB ports - driver issue?


  • Please log in to reply

#1
puzzled1965

puzzled1965

    New Member

  • Member
  • Pip
  • 9 posts
My PC's USB ports are not recognising my memory stick or camera card reader (which are working on the laptop). It does not matter which port I insert them into I still get 'device not recognised'. I tried to update/find a better driver for them through device manager and the wizaed but there was nothing available. The mouse, printer and keyboard are still working.

I am wondering whether the fact I recently plugged in an old Epson GT7000 scanner may have something to do with this. I recall ages ago I had to download a driver for it as the old CD had gone missing or was for 2000 (can't remember). This time I was prompted to find a driver for the Twain 32 or something like this which was duly found in the hard drive and there was a warning that things could go wrong on the install screen and maybe they have.

Does anyone have any suggestions? Is there a simple way to go back to default USB settings? Thanks.
  • 0

Advertisements


#2
Broni

Broni

    Kraków my love :)

  • Member
  • PipPipPipPipPipPipPipPip
  • 12,300 posts
Did you try memory stick, and camera card on another computer?

Is there a simple way to go back to default USB settings?

Go to Device Manager, and uninstall USB Controllers.
Restart computer, and they'll bee automatically reinstalled.
  • 0

#3
puzzled1965

puzzled1965

    New Member

  • Topic Starter
  • Member
  • Pip
  • 9 posts
Yes they worked in other computer.

I uninstalled USB controllers as you suggested. They reinstalled OK but ports still not working.
  • 0

#4
puzzled1965

puzzled1965

    New Member

  • Topic Starter
  • Member
  • Pip
  • 9 posts
Problem solved: Found a link which suggested shutting down and removing power lead and whaddya know it worked: something to do with residual power and USB ports playing up when they have not been used in a long time.
  • 0

#5
Broni

Broni

    Kraków my love :)

  • Member
  • PipPipPipPipPipPipPipPip
  • 12,300 posts
Ha....nice job :)
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP