Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Opera Browser Not Showing Images!


  • Please log in to reply

#1
n0ng33k

n0ng33k

    Member

  • Member
  • PipPip
  • 87 posts
Hello G2G,

I've recently had this problem with Opera where it won't display JPG or GIF or any other picture extension from a website, if that makes sense.

For example:

http://file001.thecg...sers/236834.jpg

I click on that link, the page loads, I can see Opera downloading the image, however nothing shows up, it's just a blank screen.

I've tried clearing my cache, closing + re-opening Opera, refreshing, just about everything. Nothing works.

Help?

Thanks.
  • 0

Advertisements


#2
nickchoo1994

nickchoo1994

    Member

  • Member
  • PipPip
  • 15 posts
Hey, I had this problem before so I'll try to help. At the bottom right of Opera, there's a camera icon. Click on the drop arrow button and select Show Images.

Alternatively, you can go to View>Image>Show Images.

Hope this helps.
  • 0

#3
n0ng33k

n0ng33k

    Member

  • Topic Starter
  • Member
  • PipPip
  • 87 posts
Hi Nickchoo, thanks for the reply.

I tried both things, reset the browser, and I'm still unable to see images. I had to switch to FireFox momentarily just to view the pictures.

Pweez help?
  • 0

#4
nickchoo1994

nickchoo1994

    Member

  • Member
  • PipPip
  • 15 posts
Hey,

Maybe you could try going to Start>Control panel>Internet options>Advanced>Under Multimedia make sure the "Show Pictures" is checked.

Make sure that you do not have any programmes that block images from showing.

If this fails, you could try re-installing Opera.

Also, It would be good if you could post a screenshot of what happened when you try to load images so I could have a better picture of your situation.

Thanks
  • 0

#5
n0ng33k

n0ng33k

    Member

  • Topic Starter
  • Member
  • PipPip
  • 87 posts
Hi Nick,

I uninstalled Opera, re-installed it, checked that option in the Control Panel, and it still does not show images. I am pretty sure I don't have a program blocking images because I can see them perfectly fine in IE or FireFox (I use Opera for personal preference.)

It is not letting me upload a screenshot, but I think you get the idea. If I did a Google Image search on cheese for example, the results would show up, however when I click on a picture, I can see the page loading and downloading the image, however nothing shows up afterwards.
  • 0

#6
PeteBlan

PeteBlan

    New Member

  • Member
  • Pip
  • 2 posts
I've got a similar problem with Opera.

It will display jpeg images with no problem whilst displayed via html but if I try to load a jpeg file directly into a frame or page it loads the image into Windows Picture Manager instead.

Don't have this problem with gif files however.

?
  • 0

#7
PeteBlan

PeteBlan

    New Member

  • Member
  • Pip
  • 2 posts
Cracked it!

Tools->Preferences->Advanced->Downloads

selected Mime type "image/jpg"

Edit-> Chose "Open with "Opera"

Job done! :)
  • 0

#8
wiona

wiona

    New Member

  • Member
  • Pip
  • 1 posts
so, I've had the same problem back home and I thought the PC was slow, and that why the pics cannot load. XD
But now I've come home with my dual core mega monster that I had in my apartment, and the "monster" couldn't open pictures in Opera as well. XD
So I was pissed, and I couldn't find a solution online. (What the...). When I was snooping around I've accidental solved the problem. XD. (I made my IE default browser, so I wanted to change it back to Opera, so I've try to find a solution 4 that. and then it happend. lol.)

So how to make your Opera browser display Google pics.?
1. Go to Settings-> Preferences-> Programs
2. there you'll see a check box saying " Check if Opera is a default browser on startup." Right of that U have a button
"Details..."
3. Click on that button. =)
4. You'll see a File types handled by Opera, and protocols handld by Opera.
5. I've just clicked " Select all". (don't forget to save it. ;P)

And there U go. Google whatever U want, the pictures will show up magically.
I hope someone will find this useful. :)
  • 0

#9
spadersexton

spadersexton

    New Member

  • Member
  • Pip
  • 1 posts
OMG! I know this thread is old but you are a life saver Wiona! I had this problem too with Opera not showing any images on forums etc. etc. but your solution worked! Thank you!
  • 0

#10
buythiscomputer

buythiscomputer

    New Member

  • Member
  • Pip
  • 1 posts
Thank you for your help to all but I tried everything written on this page and nothing worked !

Am I the only one to still have the problem ?


Thanks again.
  • 0

#11
FSLife

FSLife

    New Member

  • Member
  • Pip
  • 1 posts
I've also tried everything on this page - and from other forums. Opera has never displayed images from my website and I find this very frustrating as all the other browsers display it with no problem. (Firefox; Safari; Chrome; IE.) It seems the only solution for me is to stop using Opera!
  • 0

#12
jimmyworlds

jimmyworlds

    New Member

  • Member
  • Pip
  • 1 posts

having the same issue, tried all solutions in the threads none worked. It only dont show SOME images for me suddenly. And its messing up some other websites too like it was in "user mode" but its not.

 

Still using the last good version 12.17 ( i have the newer opera too which doesnt have the problem but i dont really like it) 

 

Anyone found a diffrent solution please post. 


  • 0

#13
DC Rock

DC Rock

    New Member

  • Member
  • Pip
  • 1 posts

having the same issue, tried all solutions in the threads none worked. It only dont show SOME images for me suddenly. And its messing up some other websites too like it was in "user mode" but its not.

 

Still using the last good version 12.17 ( i have the newer opera too which doesnt have the problem but i dont really like it) 

 

Anyone found a diffrent solution please post. 

OK I found this thread because Opera, which I switched to not long ago, has been driving me crazy by not showing certain pics on Twitter. It would just be blank or as I scrolled down to a video it would suddenly vanish. None of the solutions here worked for me, possibly because this thread started in 2010. What I found that did work: Settings > Websites > Pop-ups > Manage Exceptions. I had it set to not allow any sites to show pop-ups, but when I went into Manage Exceptions I typed in twitter.com and then clicked the Done button. I refreshed the twitter tab on a particular account that had been nothing but blank spots and suddenly I could see everything!!!

 

This may not solve everyone's issues but it solved mine, just when I was about to switch to something else yet again. Opera...you are safe, for now.  ;)


  • 0






Similar Topics

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP