Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Video Drivers Wont Load


  • Please log in to reply

#1
jasondraime

jasondraime

    New Member

  • Member
  • Pip
  • 1 posts
Hi I'm running Vista Ultimate 64bit (unfortunately its an upgrade not a clean install) but everything was working perfectly fine. I installed my mobo drivers and applications and updated Windows. Then I installed the drivers for my video card (VisionTek HD3870) and when I restarted the video drivers wouldnt load. I narrowed it down to my video drivers because it will boot into safe mode every time with no problem and if I uninstall the drivers then I can boot into normal windows. On visiontek's website the driver they offer is Catalyst Control Center 8.6. That didnt work. I went through AMD's website and they provide Catalyst Control Center 8.9. That didnt work either. They also offer just the card driver and leave out CCC but again I had no luck. I could really use some help here. Thanks!

Specs:
MSI Platinum P45 Hardcore Edition
8GB G Skill DDR2 PC6400 800Mhz
VisionTek HD3870 512mb DDR4
Core 2 Duo 2.0Ghz (OC'd 2.8)
Thermaltake 550w Modular Cabling PSU
Thermaltake V1
Western Digital 200GB SATA II
Raidmax Smilodon Case

Edited by jasondraime, 13 October 2008 - 04:38 PM.

  • 0

Advertisements







Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP