Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Long time start-up at XP


  • Please log in to reply

#1
klingiertr

klingiertr

    New Member

  • Member
  • Pip
  • 4 posts
Hi,

I have just got a new HP Laptop Compaq 6710b with originally installed MS Vista OS. I have downgraded it to XP Professional with SP3. I have installed all necessary drivers from HP.

My problem is, I have to wait over 2 minutes after logon screen to start the Windows.
It looks that the system waits for network connections (LAN, Wireless, Bluetooth).
Sometime it shows a communicate "Wait while TPM is connected). I have recognised that only one service starts after mentioned 2 minutes delay - alg.exe.

I have started the system in "clean" mode, and it starts fast and smoothly, within seconds.

How can I find what is the reason of such strange activity, what can I do to avoid such long delay?
  • 0

Advertisements


#2
phillip22

phillip22

    Member

  • Banned
  • PipPipPip
  • 147 posts
ALG.EXE is a Microsoft system file which runs the Application Layer Gateway as a service -- only loads if you're using the built-in XP Firewall.
So if that's causing the delay you might want to try installing a third-party firewall (which are more secure than the built-in one anyway). You should check that the Application Layer Gateway service has been stopped if you do go down that route, and if it hasn't, disable it manually.
I've disabled it on my rig (I use a third-party firewall) and have had no errors or problems with it set disabled.

However, it may be that the HP TPM driver (for the on-board security chip) is actually causing the delay and ALG.exe cannot load until TPM has connected. The problem there is that if you disable the loading of it's driver (or uninstall it), Windows will complain every time you boot up, since the associated hardware (the TPM chip) is still in place.

Try the easiest option. Install a third-party firewall, disable the built-in one, and make sure ALG.exe is not running - if it is, stop the ALG service and disable it manually. Start-->>Run: type SERVICES.MSC -- click ok. Look for Application Layer Gateway service. Double-click it to change it's settings.
  • 0

#3
klingiertr

klingiertr

    New Member

  • Topic Starter
  • Member
  • Pip
  • 4 posts
Hi,

I have stopped the alg.exe, and uninstalled all HP Security tools which, and I have checked that i have adequate drivers installed for TPM module.

Unfortunately there are no change. I have still wait almost 2 minutes for network devices. It looks that the reason is in other place. Ca it be produced by network settings?

Rgds,
R.K.
  • 0

#4
jt1990

jt1990

    Member 1K

  • Member
  • PipPipPipPip
  • 1,519 posts
When you downgraded to XP, did you format the hard drive or just run an "upgrade" install?
  • 0

#5
klingiertr

klingiertr

    New Member

  • Topic Starter
  • Member
  • Pip
  • 4 posts
I have formatted the HDD
  • 0

#6
jt1990

jt1990

    Member 1K

  • Member
  • PipPipPipPip
  • 1,519 posts
Hmm....What are the computers specs? (Not that it should make a difference - any machine that was built to run Vista should run XP just fine...)
  • 0

#7
klingiertr

klingiertr

    New Member

  • Topic Starter
  • Member
  • Pip
  • 4 posts
Well,

this is a really long list, what you exactly expect?

Base info:
HP Compaq 6710b With Win XP SP3

Here you can find detail info : http://h18000.www1.h...a/12685_na.HTML

Look for model KE124EA#AKD with Intel Core 2 Duo Processor T9300 (2.50-GHz, 800-MHz FSB, 6-MB L2 cache). 3G RAM, 15.4-inch diagonal WSXGA+ WVA anti-glare (1680 x 1050 resolution), 160-GB 5400 rpm SMART SATA etc.

Rgds,
R.K.
  • 0

#8
jt1990

jt1990

    Member 1K

  • Member
  • PipPipPipPip
  • 1,519 posts
Ok, by all rights, that comp is fast enough to be running XP at a whiz-bang speed. And you formatted the hard drive, so there's nothing leftover from Vista that could be messing things up, that makes me think that the problem is somewhere in XP, not a hardware issue.

Lemme think about this, and I'll get back to you. I've got classes today, so I probably won't have much time to do some thinking/research, however if I haven't responded by tomorrow afternoon or so, feel free to pop me a PM and remind me :)
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP