Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

right-clicking problem

  • Please log in to reply




  • Member
  • PipPipPip
  • 254 posts
I don't know when this problem started, because i've been playing a whole lot of LOTRO lately, not any of my FPS games.

Anyway, the LOTRO expansion came out, I was waiting for it to download the updates, so I was like "I'll go play some other game" and started up FEAR.

Everything ran perfectly fine except for one problem. When I right clicked to zoom/aim (default is shift, I changed it), occassionally it would do it properly, but more often than not, it would 'double click' or something. Meaning I would start to zoom, then he'd just go back to normal.

I got way pissed off, uninstalled my mouse drivers (I've got a Razer Copperhead, btw), downloaded the drivers again, updated the firmware on my mouse, and still not working

Some info on my mouse:
Razer Copperhead, Driver version 6.09, Firmware version 6.18

Anyway, FEAR kept having the problems, so I moved onto a different game - a CoD4 pre-release demo. Same problem here. All of these games worked fine a while ago, I know I was playing the CoD4 demo about a week ago perfectly fine, and i've not made any changes since then, so this is confusing me REALLY badly.

Any help is appreciated.


EDIT: Oh, and a quick not. When i right-click in windows, it doesn't screw up. Just brings up the menu as it should, nothing out of the ordinary there. It's only when I try these games. I'll go try a few more FPS games I have and see if the problem is occuring there.

EDIT: I tried out Soldier of Fortune: Payback, and Crysis. The problem didn't occur here in either, so I tested out FEAR again, and the problem remained. I went back into the controls and set the zoom/aim back to shift, as it is default, and the problem didn't happen with this, so i'm presuming it has to be my mouse.

Edited by Seltox, 17 November 2008 - 10:48 PM.

  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP