Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Windows stopped recognizing keyboard/touchpad, while Linux do


  • Please log in to reply

#1
Silverspell

Silverspell

    New Member

  • Member
  • Pip
  • 1 posts
Ok here is the story that is toying with my mental health...

I consider myself to have a fair knowledge of Windows Oss, since i've been using/tweaking them for the past 13 years. I recently decided, after getting some incentives from the fact I had a Linux pc at work, to install on my Acer Aspire 5672 laptop, Ubuntu, and switch from a dual-boot Windows XP SP3/WIndows Vista SP1 system to a Windows XP SP3/Ubuntu one. Everything is fine for a while, I upgrade from Ubuntu 8.04, to Ubuntu 8.10 and a couple of weeks pass where I was messing up linux while learning. So at one point I decide to reinstal Ubuntu.

I am saying all of the above not to necessarily link the events that led to what you will read next, but to create a timeline...the events can as well be completely irrelevant to each other.

I reinstall Ubuntu 8.10, do all the updates and finally when all is set and done, I decide to boot in Windows. Curiously enough GRUB was not touched from the whole reinstallation process. I log into windows and the system starts to hang, taking 15 minutes to boot. Got stuck on the loading after the welcoming screen, showing only desktop and no bars/icons. After it eventually loaded, my keyboard and touchpad didnt respond at all (although they do respond in BIOS). My USB connected mouse worked. I decide to do a couple of restarts to see if the problem persists. Yes same issue. I log back into linux. Touchpad, keyboard works like a charm. No problem there.

And here is the chain of events that followed:

  • I do a clean installation of my Windows Partition. My laptop has a hidden partition for system recovery. I start it up, and make a factory installation of windows (which thank god didn't erase my GRUB). After it transfered all the files, it reboots and takes me to the usual first screen of a fresh windows installation where you set up your username, time, and network name... and to my surprise, even though, in the recovery menu everything worked great, here again...Keyboard and touchpad don't work!?. I switch back to Linux, everything still working fine.
  • I install from another Windows XP cd I have. Same issue.
  • I boot from a Gparted boot disk, delete all of my partitions, reformat to fat 32. Try to reinstall from the hidden partition. Same issue
  • I delete all partitions, including the hidden one, reformat everything to fat32. Run the installation from my backup WinXP cd. Same issue.
  • I rewrite the MBR from WinXP boot disc. Same issue.
  • I install WinVista -thinking they are using different drivers- . Installation moves on fine. After reaching the point where you set up your Country.... We are now talking about a hard drive that has been swept clean ..Same issue.
  • I install Ubuntu 8.04. Everything works fine.
  • I download the Seagate Hard Drive tools, that apply to my Hard Disk. I run Short Test without any errors. I run Long test, where it found 3 errors which it claims to have corrected. Installed Windows Vista (my recovery disc doesn't work, so i am downloading a DvD from Acers' website, that i think/hope its for this use). Installed Vista --Same problem-- used a USB keyboard. Did all the updates, installed the drivers. My keyboard and touchpad seem to be kind of responding now with extreme delay and freezing. The system also generally takes extreme amount of time to do any installation or process. The USB ones are working fast and perfectly.
  • Run chkdsk... no problems detected.
  • Decide to do a low-level format on the Hard Drive. Load the Seagate Hard Drive tools, do the LLF, and install Windows XP. Same issue.
  • Update my BIOS to the latest version...just in case. Same issue.
  • I also do another LLF and try to install WinXP on a partition further inside the hard drive to possibly avoid bad clusters in the beginning of the drive. Same issue.
  • Reinstall Ubuntu 8.04, that work.

I am at a loss and would extremely appreciate any help/ suggestions.

PS1: Contacted Acer with no luck.
PS2: Was thinking of buying a new hard drive but it doesn't look like a hardware issue.
PS3: All my Windows CDs have been previously installed on laptop/desktop, including my own, with no problems.
PS4: Every new attempt of installing Windows was following a complete reformat/repartition of the drive either with GParted, or from the Windows Installation menu.

Edited by Silverspell, 20 November 2008 - 03:57 AM.

  • 0

Advertisements


#2
Gnomad1600

Gnomad1600

    Member

  • Member
  • PipPipPip
  • 160 posts
Try booting into Windows in Safe Mode and see if the issue persists. If it works then try booting into windows with the battery out.
  • 0

#3
The Skeptic

The Skeptic

    Trusted Tech

  • Technician
  • 4,075 posts
You did a great job trying to fix the problem. There are three extra things that I would try to do:

1: reset the BIOS. I saw that you installed a fresh BIOS version but still I would reset. Disconnect the battery charger and remove the battery pack. Press the power button for 1-2 minutes. Your indication that BIOS was reset is that you will have to reset time and date.

2: I would try to move the hard disk to another laptop and try the installation there. If it works well then we can be sure that the problem is not there. If it doesn't, you will have to replace it.

3: I would run memtest86 to check the RAM

I don't know where the problem is but I have a feeling that Linux, being much lighter then Windows, could manage with hardware which may be in a marginal condition. I very well may prove wrong but still, I would try the above processes.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP