Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

my sandisk micro is not available

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 1 posts
when I plug in my sandisk micro the U3 opening and then gives me a message that ""An error has occured whil intializing U3 LauchPad. Drive is unavailable or unformatted. Blah Blah Blah.

I have been using it all day back a forth from two different computers. I tried it in both computers and still get the same message. I went through the troubleshooting prompts and it can't help me. I checked for a new updated driver like the trouble shooter said and one is not available. Does anyone know how I can get the data off the sandisk and onto my hardrive??? I have lots of college papers on there that I need and can't get to.

Edited by llw, 28 November 2008 - 10:12 AM.

  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP