Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

Load needed DLLs for Hal

  • Please log in to reply




  • Member
  • PipPip
  • 47 posts
This is the first time I've posted anything on this type of forum, and it's because I believe I've met my match. I am trying to fix a Windows Server 2003 Standard Edition which has recently stopped working. The problems began when the server somehow installed updates when it is setup not to install ANY updates. When I accessed it yesterday morning, the screen says to reboot to finish the installed updates. The reason I even bothered looking at it was because the network was down. It is a Domain Controller DHCP host, with Active Directory, and is setup for file sharing. At the time, none of the computers on the network could access the shared drive, reading a message like "can't access drive; local name already in use," or something to that effect. My thoughts were to reboot the Server to finish the updates. No dice. It rebooted fine, but no change to the network situation. So I tried a restore using Directory Services Restore mode, but only to the System State backed up on 10/02/08, (server install on 09/24/08) not including the files and folders, and not overwriting anything. Everything seemed to go fine until I tried rebooting. That's when the Load Needed DLLs for Hal came up. My current knowledge told me that there were some drivers missing off the hardware access layer list, and research confirms that.
Here's the catch. I've gone through and replaced the Hal.dll and ntoskrnl.exe files, and I'm to the point where it's saying the ntoskrnl.exe is corrupt or missing. I've even tried renaming the ntosmp.exe (I think that was the name) to ntoskrnl.exe as per the setup.log file, but it's a no-go still.

A little physical info on the machine which is affecting my work I believe: There is an Nvidia Raid controller connected to two SATA drives in RAID 0. Seeing as how I have to load special drivers when booting to Repair mode, I have a feeling that they need to be included on my Hal.dll, but I'm not sure...

I'd really appreciate any help I can get on this matter. Thanks
  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP