Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

automatic clicking?

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 1 posts
I just got a new HP laptop with Windows Vista. When surfing the web I tend to hover the pointer over the link I'm going to click on next even though I may not actually be ready to click on it yet, but it keeps clicking automatically. I don't press the button down, but it clicks all by itself. How can I turn this feature off? I think I noticed it doing it even when I'm not on the internet, when I'm just going through folders on my desktop. I went to the mouse options in the control panel, but didn't see anything about it. Or do I just have a really sensitive button? Maybe so, since it doesn't always happen, just sometimes. Please help, it's very annoying!

Edited by bg82, 30 November 2008 - 02:06 AM.

  • 0


Neil Jones

Neil Jones

    Member 5k

  • Member
  • PipPipPipPipPipPipPipPip
  • 8,476 posts
This behaviour is not Vista default. It's more likely caused by software on the computer, or the fact that on most touchpads you only have to tap the middle of the pad (accidentally or otherwise) to register a left-click. one possible fix: Go into control panel / mouse/ device settings/settings/ and UNCHECK "Enable Tapping" (this is found by highlighting tapping on left).
  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP