Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

Dell 2407wfp monitor not showing max resolution

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 6 posts
Hello, I was hoping for some help.

I was doing a screen recording in Camtasia which lasted 4 hours. When i clicked for the recording to stop, it started rendering. REndering such a long file usually takes some hours and seems to be a huge task fwiw.

Anyways, as soon as I asked stopped recording, my main monitor went blank and everything was moved to my 2nd monitor on the right side (Extended desktop) a 2007fwp (20" monitor).

I stopped the render of the video and rebooted the system. The max and current resolution was changed from 1920x1200 to 1600x1200! Ive tried uninstalling and installign the newest NVidia drivers for my GeForce 9600 GT.

Nothing seems to work. Ive tried downloading monitor drivers from Dells website, but they dont seem to want to be recognized by windows and Windows has changed the name of the monitor to Standard PnP screen from 2407WFP.

Im kinda lost on what to do now,

When I did uninstall the gfx driver and rebooted, I had the newest drivers downloaded, but Windows went ahead and "looked for new drivers" for the gfx card since at startup. Even tho it said Windows was using a standard VGA Driver, i was able to install the NVidia drivers and reboot. I had to reboot manually at some point because it was taking ages shutting down the computer.

ANyways, Hope someone here can help. Should I just try un- and reinstalling the gfx driver again?
Desperately need to get back to 1920x1200 res :)

Thanks in advance for reading.

Im on a 64-bit Vista machine with 4 gigs ram and dual core 2.66 GHz. Oh btw when this happened I only had 16 GB left on my HD outta about 300. Not sure if that has any relevance. Ive deleted a bunch of stuff and now theres 65 GB free.
  • 0





  • Banned
  • Pip
  • 2 posts
Nothing seems to work. Ive approved downloading adviser drivers from Dells website, but they dont assume to wish to be accustomed by windows and Windows has afflicted the name of the adviser to Standard PnP awning from 2407WFP.


Edited by rs_shadow0000, 23 July 2009 - 09:12 AM.

  • 0



    Global Moderator

  • Global Moderator
  • 6,585 posts
rs_shadow0000 your comments don't make any sense.

I would recommend that you would uninstall your driver, if prompted to keep drivers, say no. Then use Revo Uninstaller to make sure that they are completely removed.

Reboot computer. say no to windows asking for drivers. Install the latest nvidia drivers from their website.
  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP