Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Help with sound


  • Please log in to reply

#1
=OSS*ROID=

=OSS*ROID=

    Member

  • Member
  • PipPipPip
  • 132 posts
Alright, as you can see in my sig, I have the Creative X-Fi Fatal1ty Champion series sound card. Now, Battlefield 2 has a sound option that is suppose to optimize the sound if you have a X-Fi sound card. I went to turn on the feature, and it says that your sound hardware is incompatible. Does anybody know what I can do??

Also, I have a 5.1 surround sound system, also in sig, but the X-Fi doesn't recognize all 6 speakers. The only speakers that work are the front left, front right, and the subwoofer. The center channel and the rear left and rear right do not make any sounds. I believe I have plugged everything into the right slots, so does anyone know what I can do for this??

My system specs are in my sig, and just to let you know, my bios and windows both recognize the X-Fi. I downloaded the drivers from windows update for it. I'm using windows vista 64-bit. Thanks :)
  • 0

Advertisements


#2
dave08

dave08

    Member

  • Member
  • PipPip
  • 11 posts
Go to the creative website and download the full driver and software package from there, Windows update has probably just downloaded basic drivers that dont know how to use all the capabilities of your X-Fi card.
  • 0

#3
=OSS*ROID=

=OSS*ROID=

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 132 posts
hey thanks, i downloaded the full driver and i restarted my system and the first thing I noticed was that the lights on the I/O panel were actually on :) . Then I started BF2 up and went to the sound options and the X-Fi setting worked! I still have one problem, in audio creation mode, the sound card still doesn't recognize all of my speakers, only 2.1, but when I go into entertainment mode the card recognizes all of them. Now in audio creation mode, there is a speaker setting that tells the card how many speakers you have. I set it to 5.1 but it still doesn't recognize the speakers. I like entertainment mode a lot better anyway, but it still bothers me that in audio creation mode, all the speakers don't work. Thanks for your help thus far.

Cheers :)
ROIDO

Edited by =OSS*ROID=, 20 December 2008 - 11:34 PM.

  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP