Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Task Services won't start


  • Please log in to reply

#1
cdell

cdell

    New Member

  • Member
  • Pip
  • 1 posts
Hi
I just recently found a issues in AVG, called "Back Door.Generic 10.Trojan horse. ABVU". Avg asked if I wanted to either Heal or Remove it. I tried both but it would always come back. The path was C:\windows\system32\asfsip.dll.
Every time I touched this file AVG would fire asking to Heal or Remove". I tired to delete it and I was told I didn't have access. Regedit also denied me access. And I was logged in as Admin.
Yesterday during the AVG scheduled run it said I my systemwas fine no issues. I checked and the asfsip.dll was still there but it seam inactive. Still couldn't delete it. I ran sfc /scannow thinking it was a corrupted dll and it took several hours (at least 2 for sure since I left it running and went to bed). I the morning their were no messages, just normal, like nothing happened.

So much for the story here is the issue I have: Even though I can't kill the dll my computer appears to be fine except for:
Prefetch, and Auto System Restore seam to have stopped. In subsequent searches I found that the Task Scheduler must be started to get these to run.
I go to MY Computer>Mange>Computer Management> Services and Applications > Services > Task Scheduler. It shows as Start up Type Automatic, but when click start I get the error message "Error 1717; the interface is unknown. Aslo when I go to the Event Viewer i get a Error saying "Unable to complete operation interface unknown"
on Application, Security and System.
P.S. if I initiate a manual Restore it appears to work. but when I restore to a previous date/time it says it did but I seam to remember in the past it wanted me to restart the computer, it no longer does, but indicates it successfully reset?

I would appreciate and advice and or potential options I hope I haven't created a mess
Thanks in advance for any help
Chuck
  • 0

Advertisements


#2
Onaipian

Onaipian

    Notepad warrior

  • Retired Staff
  • 2,130 posts
Hello :) and welcome to Geeks2Go! You appear to have some malware, as AVG has discovered also...

Please go to the malware forum and Start HERE....
70 percent of all problems can be solved here. If at the end of the process you are still having difficulty (and you may not be) then start a new topic in the Malware Removal - HijackThis™ Logs Go Here Forum

Edited by piano9playa5, 23 December 2008 - 05:27 PM.

  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP