Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Weirdness with File Types, Icons, and Actions


  • Please log in to reply

#16
IntoTheForge

IntoTheForge

    Member

  • Topic Starter
  • Member
  • PipPip
  • 15 posts
Those settings are already set to what you're saying, they're the first things I checked. Drive, Directory, and Folder all have identical keys in HKEY_CLASSES_ROOT\*\shell. Find and Open have always been the only two choices under actions for Drive, File Folder and Folder, with none of them ever having a default.
  • 0

Advertisements


#17
Throoper

Throoper

    Member

  • Member
  • PipPipPip
  • 155 posts
Not Lorenz, Murphy.

Check these values.

HKCR\Directory\Shell\Open Should be Default REG_SZ (value not set)

HKCR\Directory\Shell\open\command Default REG_SZ C:\WINDOWS\explorer.exe "%1" (space between the exe and "%)

Back in your first post, you did a workaround linking open to explorer.exe. I'm thinking you didn't add the "%1" and that's what's wrong.

I hope.
  • 0

#18
Throoper

Throoper

    Member

  • Member
  • PipPipPip
  • 155 posts
One other thing to check is HKLM\Software\Classes\Directory\shell. The values should be identical to the ones under HKCR.
  • 0

#19
IntoTheForge

IntoTheForge

    Member

  • Topic Starter
  • Member
  • PipPip
  • 15 posts
.\shell\Open\command - Default (REG_SZ) is %SystemRoot%\explorer.exe "%1". The registry fix from that site you linked in #6 fixed all that, and yes you were right, I forgot the %1. The original problem of nothing opening right in the first place was snubbed when I applied the reg fixes, the new problem is the folder sidebar issue.
  • 0

#20
Throoper

Throoper

    Member

  • Member
  • PipPipPip
  • 155 posts
Hmm! The sidebar might be coming from the Folder rather than the Directory.
Quick way to find out would be to run the Folder reg fix from the site. Won't hurt and will eliminate that.
  • 0

#21
Throoper

Throoper

    Member

  • Member
  • PipPipPip
  • 155 posts
I'm going to guess that the Folder was fine and the reg fix made no difference.

This is a shot-in-the-dark.
Folder Options>File types>File Folder>Advanced.
Highlight Open and click Remove, leaving only Find as an Action (make sure it's not bold indicating default).
OK and see if there's a difference.
If not, check the Directory\shell key and set the value to NONE and see if it works.
If not, recreate the Open action and try again.
If still wrong, click the Edit button and check what's on the edit window for Open.
It should be:

Application used to perform action: C:\WINDOWS\explorer.exe "%1"

Check mark by Use DDE.

Application: explorer

Topic: System


If it's correct, go to the Directory\shell key and make sure the value is NONE.
  • 0

#22
IntoTheForge

IntoTheForge

    Member

  • Topic Starter
  • Member
  • PipPip
  • 15 posts
Edit and Remove buttons are disabled on Drive, File folder and Folder, and Directory\shell is already set to none. I think the registry fixes on that guy's site did the folder sidebar thing.
  • 0

#23
Throoper

Throoper

    Member

  • Member
  • PipPipPip
  • 155 posts

Edit and Remove buttons are disabled on Drive, File folder and Folder

Doh!!! Forgot that's the default. Go to the Directory key and change the Edit Flags D-word value to 2. That will activate the buttons.

I think the registry fixes on that guy's site did the folder sidebar thing.

I'll download them and go through them. I'll compare it to mine and see if anything pops. If you haven't already done the Folder, hold off till I look it over(check that Folder/shell has open for the value), but go ahead and try doing the File types edit from my last post.
  • 0

#24
IntoTheForge

IntoTheForge

    Member

  • Topic Starter
  • Member
  • PipPip
  • 15 posts
I already used the guy's Drive, Directory, and Folder fixes in one go when you linked to it. When I delete Open, find automatically becomes the default action and I don't know how to stop it doing that. Folder has a weird value for Folder\shell\open\command - %SystemRoot%\Explorer.exe /idlist,%I,%L. shell\explore\command = %SystemRoot%\Explorer.exe /e,/idlist,%I,%L. Is it possible for me to save parts of the registry for you to look at, like just the keys under the folder key? It looks like it could be the Folder fix if anything.

Edited by IntoTheForge, 10 January 2009 - 06:10 PM.

  • 0

#25
Throoper

Throoper

    Member

  • Member
  • PipPipPip
  • 155 posts
I checked over the Folder reg and it's fine. The values you have are correct.
The only difference (except for the stuff I've done, context menus and such) is the Folder\shell has a value of open on mine. That's because I have Open as the default action for Folder.

The Directory reg on the other hand has a difference. There's no shell\open. Other than that, it looks good.
So when you remove open from the Folder Options>File Types tab>File Folder edit, check the Directory\shell key and if open is still a subkey, delete it so only the find subkey remains. The value of the shell key itself is likely Find. To remove Find as Default, change the value of the shell key to NONE.
When you're done, the File Folder window will only have Find as an action (but not set as default) and the Directory\shell key will only have Find as a subkey.
Give it a try to see if the folders open right.
If not, create the new action open as I said in post #21.
  • 0

Advertisements


#26
IntoTheForge

IntoTheForge

    Member

  • Topic Starter
  • Member
  • PipPip
  • 15 posts
Now this is getting Heisenberg freaky. I changed everything just like you said - no difference. Folder sidebar has to be up, nothing retains its view. I did what you said in post 21, but using %SystemRoot% instead of C:\WINDOWS\ in the Open action gives Explorer and any program accessing any folder an access is denied error... I changed it to C:\WINDOWS\ instead of having no open action - Opening drives now opens the drive root in a new Explorer process and window...

HKCR wasn't the only root key edited by those fixes, if memory serves...
  • 0

#27
Throoper

Throoper

    Member

  • Member
  • PipPipPip
  • 155 posts
I think we have a winner.
Go to HKCR\Directory\shell\find and delete the Find key.
Try your folders and see if they will work the way you want.
If that clears up the problem, I'll send you a reg to put the action back with the correct values.
  • 0

#28
Throoper

Throoper

    Member

  • Member
  • PipPipPip
  • 155 posts
Just found the secondary problem and have sent you the fixes.
It wasn't the reg fixes from Doug. You got caught with the dreaded Windows "How dare you try to change what we decided was right" bug.
  • 0

#29
IntoTheForge

IntoTheForge

    Member

  • Topic Starter
  • Member
  • PipPip
  • 15 posts
Alright coolness - the file folders are fixed. I can click on My Computer and My Documents and File Folders retain their views.




Now Win+E and Drives are doing it. should I get rid of that find thing on Drive?

Edit: I changed HKCR\Drive\shell - (Default) to Open and copied the open command from Folder and Drives open up correctly. the only thing left is to try and figure out why Win+E opens in the mode I've been trying rid myself of. I hope I never see the folder sidebar again. What command is Win+E even executing in the first place?

WHAT WE HAVE HERE MICROSOFT IS A FAILURE TO COMMUNICATE.

Edited by IntoTheForge, 12 January 2009 - 06:29 PM.

  • 0

#30
Throoper

Throoper

    Member

  • Member
  • PipPipPip
  • 155 posts
Just to be sure we're on the same page, you got the reg fixes I sent and deleted your find key and then ran both reg files, then set the Folder\shell to open?

If that's correct, check the HKCR\Drive\shell to be sure the value is none.
Win+E does open in Explorer mode.

Edit: Just went through my reg file for Drive and open wasn't a listed action and the default is none.
I see on yours open is an action but your default was set to explore, so if changing it to open works, quit while you're ahead. Like I said, Win+E will open in full explorer mode with the sidebar and it's supposed to so don't try to change it.

Edited by Throoper, 12 January 2009 - 06:57 PM.

  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP