Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

DSL speed runs rediculously slow


  • Please log in to reply

#1
SethKx

SethKx

    Member

  • Member
  • PipPip
  • 10 posts
Hello. I have a problem that is killing me.

Problem:
The internet speed on my laptop runs rediculously slow.


Details:
I have a laptop that runs Windows Vista, and I use Internet Explorer.

I have a DSL wireless router (Actiontec GT704WG). Whenever I try to run the internet connection from that router on my lap top, it connects, but it runs unbearably slow. For most sites, as slow or slower than Dial up.

My usual method is connecting wireless, but I have tried to connect both wired and wireless, each time it runs at the same speed.

Now the real frustrating and confusing part is that the speed is fine when I connect to other wirelss connections. And the connection in question runs perfectly fine on the desktop computer it is wired to. It has also run fine on other people's wireless laptops.

Things I have tried:
Again, I have connected my laptop directly to the router, and tried it wirelessly with excellent signal strength.
I have tried all that I could with any known firewalls. Disabling, what have you.
I have completely cleared all cookies and cached files, even setting IE back to it's default settings.


SO. Basically it seems that the connection specific to my home router is unusually slow specifically with my laptop.


It's incredibly frustrating and confusing.

ANY help would be greatly appreciated.

Thanks
  • 0

Advertisements


#2
Broni

Broni

    Kraków my love :)

  • Member
  • PipPipPipPipPipPipPipPip
  • 12,300 posts
Did you try to cennect the computer straight to the modem?
  • 0

#3
SethKx

SethKx

    Member

  • Topic Starter
  • Member
  • PipPip
  • 10 posts
Yes I have. It runs at exactly the same slow speed when I have wireless.

I think I've tried every "usual" step one might do when the internet runs slow.

I keep thinking maybe its some setting I have to change on my computer? The only problem is what and where.
  • 0

#4
Broni

Broni

    Kraków my love :)

  • Member
  • PipPipPipPipPipPipPipPip
  • 12,300 posts
Try these steps....

If that doesn't work...
Go Start>Run (Start search in Vista), type in:
cmd
Click OK.

In Command Prompt window, type in following commands, and hit Enter after each one:
ipconfig /flushdns
ipconfig /registerdns
ipconfig /release
ipconfig /renew


Restart computer.

If that doesn't work...
Go Start>Run (Start search in Vista), type in:
cmd
Click OK.

At Command Prompt, type in:
netsh int ip reset reset.log
Hit Enter.
Type in:
netsh winsock reset catalog
Hit Enter.

Restart computer.


If that doesn't work...
Download, install, and run WinSockFix: http://www.softpedia...inSockFix.shtml
Restart computer, and check again.
  • 0

#5
SethKx

SethKx

    Member

  • Topic Starter
  • Member
  • PipPip
  • 10 posts
Alright, I began to try the first set of steps you suggested. After I hit enter after each command, it tells me "The requested operation requires elevation".

Any idea what that means?
  • 0

#6
Broni

Broni

    Kraków my love :)

  • Member
  • PipPipPipPipPipPipPipPip
  • 12,300 posts
OK.
Start over.
Go Start, and in "Start search" type in:
cmd
Hold CTRL, and SHIFT, press Enter. That will allow you to run "cmd" as administrator (elevated).
  • 0

#7
SethKx

SethKx

    Member

  • Topic Starter
  • Member
  • PipPip
  • 10 posts
Ahh I see. ok thanks. commencing steps now
  • 0

#8
Broni

Broni

    Kraków my love :)

  • Member
  • PipPipPipPipPipPipPipPip
  • 12,300 posts
No problem. It's good to remember this trick.
  • 0

#9
SethKx

SethKx

    Member

  • Topic Starter
  • Member
  • PipPip
  • 10 posts
Well alas I've gone through every step, wireless and wired, but no apparent change.

When I ran the winsock fix, it went through the process, however at one point a notice came up stating "registry import information not found". It apparently finished it's process though, so I dont know what that was.

Maybe there's something I need to change within the modem settings?
  • 0

#10
Broni

Broni

    Kraków my love :)

  • Member
  • PipPipPipPipPipPipPipPip
  • 12,300 posts
Download, and install TCP Optimizer: http://www.speedguid...t/downloads.php
Open it, and put a checkmark in Optimal Settings. Click Apply changes button.
Restart computer, and see if it helped.
  • 0

Advertisements


#11
SethKx

SethKx

    Member

  • Topic Starter
  • Member
  • PipPip
  • 10 posts
Heh I ran it numerous times, but no apparent luck once again.

I'm beginning to think this is a lost cause. :)
  • 0

#12
Broni

Broni

    Kraków my love :)

  • Member
  • PipPipPipPipPipPipPipPip
  • 12,300 posts
Never :)
Did you try Safe Mode with Networking?
What firewall, and AV do you use?
  • 0

#13
SethKx

SethKx

    Member

  • Topic Starter
  • Member
  • PipPip
  • 10 posts
I'm not sure how to do Safe mode with networking

I believe my firewall and AV is the McAfee program that came with my laptop
  • 0

#14
Broni

Broni

    Kraków my love :)

  • Member
  • PipPipPipPipPipPipPipPip
  • 12,300 posts
Restart computer, and keep tapping F8 key, until menu appears.
  • 0

#15
Broni

Broni

    Kraków my love :)

  • Member
  • PipPipPipPipPipPipPipPip
  • 12,300 posts
BTW, did you try Firefox?
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP